Bug 15605 - Only 1mb detected with Neomagic NM2160
Summary: Only 1mb detected with Neomagic NM2160
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-07 06:29 UTC by Jeremy Katz
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 06:29:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2000-08-07 06:29:36 UTC
(Note: this is actually Xconfigurator 4.3.40 instead of the version shipped
in pinstripe)

Xconfigurator is only detecting 1 out of 2.5 megs of video memory on a
Neomagic NM2160 (MagicGraph 128XD).  lspci -vv gives:

00:08.0 VGA compatible controller: Neomagic Corporation NM2160 [MagicGraph
128XD] (rev 01) (prog-if 00 [VGA])
        Subsystem: Sony Corporation MagicGraph 128XD
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 9
        Region 0: Memory at fd000000 (32-bit, prefetchable)
        Region 1: Memory at fea00000 (32-bit, non-prefetchable)
        Region 2: Memory at fed00000 (32-bit, non-prefetchable)

Not a major bug since you can just select 2 megs, but it could confuse
people who don't really know much about their hardware

Comment 1 Trond Eivind Glomsrxd 2000-08-07 13:50:45 UTC
The VESA BIOS call in kudzu returns 1 MB (just as any NVIDIA card returns 4 MB)
- sorry, can't fix.


Note You need to log in before you can comment on or make changes to this bug.