Bug 1560541 - LB operation status is offline but LB works
Summary: LB operation status is offline but LB works
Keywords:
Status: CLOSED DUPLICATE of bug 1506644
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Carlos Goncalves
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-26 12:20 UTC by Alexander Stafeyev
Modified: 2019-09-10 14:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-16 15:07:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1506644 high CLOSED Add support for configuring 'in-overcloud' resources for octavia through workflows and ansible 2020-10-14 00:28:05 UTC

Internal Links: 1506644

Description Alexander Stafeyev 2018-03-26 12:20:58 UTC
(overcloud) [stack@undercloud-0 ~]$ openstack loadbalancer show  59b5d800-c01c-4c28-a94b-30570355e615
+---------------------+--------------------------------------+
| Field               | Value                                |
+---------------------+--------------------------------------+
| admin_state_up      | True                                 |
| created_at          | 2018-03-26T09:13:23                  |
| description         |                                      |
| flavor              |                                      |
| id                  | 59b5d800-c01c-4c28-a94b-30570355e615 |
| listeners           |                                      |
| name                |                                      |
| operating_status    | OFFLINE                              |
| pools               |                                      |
| project_id          | 8c67e8bec298475db2c2c79063410f16     |
| provider            | octavia                              |
| provisioning_status | ACTIVE                               |
| updated_at          | 2018-03-26T09:14:17                  |
| vip_address         | 192.168.2.6                          |
| vip_network_id      | dcdcdd0a-9311-4a57-b5e0-99ba92702f5b |
| vip_port_id         | e0abfee1-0d5a-4a58-9f17-19a4aba70c0c |
| vip_qos_policy_id   | None                                 |
| vip_subnet_id       | 2ed7d0ff-bb56-4ff0-90bb-b57076ac5123 |
+---------------------+--------------------------------------+
(overcloud) [stack@undercloud-0 ~]$ curl 10.0.0.219
lbtree-server2-s4hkq2h4tqsp(overcloud) [stack@undercloud-0 ~]$ curl 10.0.0.219
lbtree-server1-4jiy4jntoyji(overcloud) [stack@undercloud-0 ~]$ curl 10.0.0.219
lbtree-server2-s4hkq2h4tqsp(overcloud) [stack@undercloud-0 ~]$ curl 10.0.0.219
lbtree-server1-4jiy4jntoyji(overcloud) [stack@undercloud-0 ~]$ curl 10.0.0.219
lbtree-server2-s4hkq2h4tqsp(overcloud) [stack@undercloud-0 ~]$ 




2018-03-25 09:15:22.814 21 INFO octavia.controller.queue.endpoint [-] Creating load balancer 'f4d91b66-9326-43e7-a7f5-ffaecafd5428'...
2018-03-25 09:15:22.999 21 INFO octavia.controller.worker.tasks.database_tasks [-] Created Amphora in DB with id ad471695-02b2-426d-8628-abb9700e9807
2018-03-25 09:15:23.087 21 INFO octavia.certificates.generator.local [-] Signing a certificate request using OpenSSL locally.
2018-03-25 09:15:23.088 21 INFO octavia.certificates.generator.local [-] Using CA Certificate from config.
2018-03-25 09:15:23.088 21 INFO octavia.certificates.generator.local [-] Using CA Private Key from config.
2018-03-25 09:15:23.088 21 INFO octavia.certificates.generator.local [-] Using CA Private Key Passphrase from config.
2018-03-25 09:16:10.713 21 INFO octavia.controller.worker.tasks.database_tasks [-] Mark ALLOCATED in DB for amphora: ad471695-02b2-426d-8628-abb9700e9807 with compute id dcb77091-7462-4062-89eb-44194f813e51 for load balancer: f4d91b66-9326-43e7-a7f5-ffaecafd5428
2018-03-25 09:16:11.071 21 INFO octavia.network.drivers.neutron.allowed_address_pairs [-] Port 1548e570-b113-4346-9eaf-2aed86f46b54 already exists. Nothing to be done.
2018-03-25 09:16:30.951 21 INFO octavia.controller.worker.tasks.database_tasks [-] Mark ACTIVE in DB for load balancer id: f4d91b66-9326-43e7-a7f5-ffaecafd5428
2018-03-25 09:16:32.082 21 INFO octavia.controller.queue.endpoint [-] Creating listener '8685faa3-0958-46a4-b905-c1405078fdf6'...
2018-03-25 09:16:34.717 21 INFO octavia.controller.queue.endpoint [req-47678462-79bf-4dd0-9663-956ec4a40abb - 8c67e8bec298475db2c2c79063410f16 - - -] Creating pool '4245b2fc-a320-4a0e-a80b-5abfc38edf97'...
2018-03-25 09:16:36.345 21 INFO octavia.controller.queue.endpoint [-] Creating health monitor 'd02e36db-a5d5-41b3-a3da-246b9d415320'...
2018-03-25 09:16:37.014 21 INFO octavia.controller.queue.endpoint [-] Creating member 'f778a427-354f-4219-9c61-5e002d6808f8'...
2018-03-25 09:16:38.644 21 INFO octavia.controller.queue.endpoint [req-4ae81077-68a5-4b4f-9564-eb3680534cf8 - 8c67e8bec298475db2c2c79063410f16 - - -] Creating member '25eaef6e-5b55-4406-8c53-44aa58a5e365'...
2018-03-25 13:41:25.722 21 INFO octavia.controller.queue.endpoint [-] Creating load balancer '2c6aaf8b-370d-47ec-991b-b7929da8f110'...
2018-03-25 13:41:25.887 21 INFO octavia.controller.worker.tasks.database_tasks [-] Created Amphora in DB with id 1f4afb9b-1c2c-4534-9abb-9ae930661a96
2018-03-25 13:41:26.008 21 INFO octavia.certificates.generator.local [-] Signing a certificate request using OpenSSL locally.
2018-03-25 13:41:26.009 21 INFO octavia.certificates.generator.local [-] Using CA Certificate from config.
2018-03-25 13:41:26.009 21 INFO octavia.certificates.generator.local [-] Using CA Private Key from config.
2018-03-25 13:41:26.010 21 INFO octavia.certificates.generator.local [-] Using CA Private Key Passphrase from config.
2018-03-25 13:41:51.441 21 INFO octavia.controller.worker.tasks.database_tasks [-] Mark ALLOCATED in DB for amphora: 1f4afb9b-1c2c-4534-9abb-9ae930661a96 with compute id fd06ef2a-d87a-49ed-8214-0b95976e2658 for load balancer: 2c6aaf8b-370d-47ec-991b-b7929da8f110
2018-03-25 13:41:52.386 21 INFO octavia.network.drivers.neutron.allowed_address_pairs [-] Port 2a9b3f99-5b90-4adc-9bcd-7a4db561fc31 already exists. Nothing to be done.
2018-03-25 13:42:06.667 21 WARNING octavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying.: ConnectionError: HTTPSConnectionPool(host='192.168.199.51', port=9443): Max retries exceeded with url: /0.5/plug/vip/192.168.2.3 (Caused by NewConnectionError('<requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x7fe4e8a27890>: Failed to establish a new connection: [Errno 111] Connection refused',))

Comment 2 Bernard Cafarelli 2018-04-16 15:07:27 UTC
Close as duplicate, the work for this specific issue was tracked in #1506644

*** This bug has been marked as a duplicate of bug 1506644 ***


Note You need to log in before you can comment on or make changes to this bug.