Bug 1560667 - qemu/migration: e1000 compatibility
Summary: qemu/migration: e1000 compatibility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dr. David Alan Gilbert
QA Contact: jingzhao
URL:
Whiteboard:
Depends On: 1578068
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-26 16:59 UTC by Dr. David Alan Gilbert
Modified: 2018-11-01 11:07 UTC (History)
9 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:07:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dr. David Alan Gilbert 2018-03-26 16:59:54 UTC
Description of problem:
The migration format of e1000 changed in qemu 2.12;  it's got code to handle forward migration, but backwards will break; we'll need a downstream hack for that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dr. David Alan Gilbert 2018-03-27 09:12:10 UTC
Upstream commit 'd62644b4 - e1000: Separate TSO and non-TSO contexts, fixing UDP TX corruption' is the change that incremented the version.

Comment 3 Dr. David Alan Gilbert 2018-03-27 11:36:21 UTC
Posted upstream:
0000-e1000-mig-change-2.12.patch:Subject: [PATCH 0/3] e1000 migration changes for 2.12
0001-e1000-Convert-v3-fields-to-subsection.patch:Subject: [PATCH 1/3] e1000: Convert v3 fields to subsection
0002-e1000-wire-new-subsection-to-property.patch:Subject: [PATCH 2/3] e1000: wire new subsection to property
0003-e1000-Old-machine-types-turn-new-subsection-off.patch:Subject: [PATCH 3/3] e1000: Old machine types, turn new subsection off

Comment 4 Dr. David Alan Gilbert 2018-03-28 16:40:04 UTC
v2 posted upstream:
v2-0000-e1000-mig-changes-2.12.patch:Subject: [PATCH v2 0/6] e1000 migration changes for 2.12
v2-0001-e1000-Convert-v3-fields-to-subsection.patch:Subject: [PATCH v2 1/6] e1000: Convert v3 fields to subsection
v2-0002-e1000-Dupe-offload-data-on-reading-old-stream.patch:Subject: [PATCH v2 2/6] e1000: Dupe offload data on reading old stream
v2-0003-e1000-wire-new-subsection-to-property.patch:Subject: [PATCH v2 3/6] e1000: wire new subsection to property
v2-0004-e1000-Migrate-props-via-a-temporary-structure.patch:Subject: [PATCH v2 4/6] e1000: Migrate props via a temporary structure
v2-0005-e1000-Choose-which-set-of-props-to-migrate.patch:Subject: [PATCH v2 5/6] e1000: Choose which set of props to migrate
v2-0006-e1000-Old-machine-types-turn-new-subsection-off.patch:Subject: [PATCH v2 6/6] e1000: Old machine types, turn new subsection off

Comment 5 Dr. David Alan Gilbert 2018-04-10 13:40:40 UTC
Merged upstream in daf6b59be8c703264765a533bc63421caef95225 

QE:
Please test with e1000 on a mix of guests OS (Linux and Windows) and that networking works across the migration (and is no worse than it was on previous versions); please check across old/new machine types.

Comment 14 Eduardo Habkost 2018-05-30 15:57:25 UTC
Bug 1578068 is now on POST.

Comment 17 Dr. David Alan Gilbert 2018-06-14 10:12:12 UTC
Jing:
  This seems to be working for me.
Given our IRC discussion there seems to be some confusion. To clarify:

a) Migration from 7.6->7.5 with the pc-i440fx-rhel7.5.0 machine type should work, even with the e1000 NIC.
b) I believe this didn't work in 2.12.0-1
c) I believe this is fixed in 2.12.0-3

Please confirm that migration now works without error.

Comment 20 errata-xmlrpc 2018-11-01 11:07:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.