Bug 156067 - OpenOffice.org icon names contain version number
OpenOffice.org icon names contain version number
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-04-27 05:34 EDT by Mark McLoughlin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.9.99-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 04:25:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2005-04-27 05:34:52 EDT
All of the icons that OpenOffice.org installs into the icon theme contain the
version number - e.g openofficeorg-19-base

Icon names should really be long term names as they will be referenced by other
apps.

e.g. because the OpenOffice.org launchers are on the default panel, the icon
name is referenced in the panel configuration. So, when OpenOffice.org goes to
2.0 and the icons become openofficeorg-20-base, you won't see the icons on the
panel anymore.
Comment 1 Caolan McNamara 2005-04-27 06:10:41 EDT
"by other apps", or "by panel"
Comment 2 Mark McLoughlin 2005-04-27 06:17:06 EDT
In practice, its probably only the panel that references these icon names - but
you could imagine some other app wanting to display an openoffice icon, using
the name openofficeorg-19-writer and then finding it breaks later ...

Note You need to log in before you can comment on or make changes to this bug.