Bug 156080 - USB Serial devices not added properly (usbserial etc)
USB Serial devices not added properly (usbserial etc)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-27 08:50 EDT by Christian Huettermann
Modified: 2013-03-06 00:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
var/log/messages with hotplug debug turned on, on 2.6.9-6.39.EL (7.51 KB, text/plain)
2005-04-28 10:27 EDT, Christian Huettermann
no flags Details

  None (edit)
Description Christian Huettermann 2005-04-27 08:50:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
When trying to activate my UMTS/3G PCMCIA card, which is known to the system as simple USB serial devices, the usbserial modules are a) failing to load, and b) when loaded manually, the devices are not created properly. Instead of creating the ttyUSB0 ttyUSB1 etc devices, it created <NULL>0 etc devices, with major and minor numbers = 0. 
Harald had a look into this and identified this as a bug in the usbserial module.


System is an IBM X31 (26725KG), running RHEL4DT.

messages, when PCMCIA card is plugged in:
Apr 27 13:45:45 konstanz kernel: ohci_hcd 0000:03:00.0: OHCI Host Controller
Apr 27 13:45:45 konstanz kernel: ohci_hcd 0000:03:00.0: irq 11, pci mem e0840000
Apr 27 13:45:45 konstanz kernel: ohci_hcd 0000:03:00.0: new USB bus registered, assigned bus number 5
Apr 27 13:45:45 konstanz kernel: ohci_hcd 0000:03:00.0: WARNING: OPTi workarounds unavailable
Apr 27 13:45:45 konstanz kernel: hub 5-0:1.0: USB hub found
Apr 27 13:45:45 konstanz kernel: hub 5-0:1.0: 2 ports detected
Apr 27 13:45:55 konstanz kernel: ohci_hcd 0000:03:00.0: wakeup
Apr 27 13:45:56 konstanz kernel: usb 5-1: new full speed USB device using address 2

[root@konstanz log]# udevinfo -q all -p /sys/class/tty/\<NULL\>0
P: /sys/class/tty/<NULL>0
N: <NULL>0
T: c
M: 020600
S:
O: root
G: root
F:
L: 0
U: 1076
R: 0

when i manually called a MAKEDEV ttyUSB, the devices were created properly and the card runs OK.



Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.5.EL

How reproducible:
Always

Steps to Reproduce:
1. plug in PCMCIA UMTS/3G card


Actual Results:  nada.

Expected Results:  USB Serial devices should be initialized and should be used as modem devices

Additional info:
Comment 1 Harald Hoyer 2005-04-27 09:34:32 EDT
the kernel module usbserial does not provide a proper sysfs "dev" file... the
path is scrambled and major and minor are "0"!!
Comment 2 Jason Baron 2005-04-27 13:31:38 EDT
So the '<NULL>'0 file is being created on (un)plug of the pcmcia card? Seems
like the usb-serial 'probe' routine isn't creating the /sys/ files correctly.
but i'm really not sure at this point. The file drivers/usb/serial/usb-serial.h
has a 'dbg' MACRO, that might help a lot in tracking this down.
Comment 3 Harald Hoyer 2005-04-28 04:43:21 EDT
The '<NULL>'0 file is being created on _plug_ of the pcmcia card after loading
usbserial by hand.
Comment 4 Christian Huettermann 2005-04-28 10:27:30 EDT
Created attachment 113784 [details]
var/log/messages with hotplug debug turned on, on 2.6.9-6.39.EL

var/log/messages with hotplug debug turned on, on 2.6.9-6.39.EL.

devices show up as 
/sys/class/tty/<NULL>0 etc, not as ttyUSB0 etc as they should.
Comment 5 Christian Huettermann 2005-04-28 10:31:18 EDT
tried my chances with the U1 kernel from RHEL4-U1-re0421.0, no joy. see
attachment above for detailled logs. udevinfo etc remains the same. 

tried to work around this by doing a MAKEDEV ttyUSB, and when the right
/dev/ttyUSB0 device is there, the card is responsive.. the workaround shouldnt
be the solution 'though.
Comment 6 Jason Baron 2005-04-28 13:26:57 EDT
I've tracked this down a bit...the /sys/class/tty/ttyUSBN file should be getting
created by 'tty_register_device', which is called from drivers/usb/serial/bus.c,
line 133. If i had to guess this routine is not being passed valid data for some
reason. There is a 'dev_info' printk on the next line that would confirm this
suspicion. We can turn that on, i think, but defining DEBUG, in
include/linux/device.h. 

Also, i don't think dbg was properly turned on in comment #4, as i see no output
from it.

If i had h/w to test this locally, that would help...any suggestions?
Comment 7 Jiri Pallich 2012-06-20 12:08:47 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.