Bug 1560916 - It is better to set default value for openshift_prometheus_node_exporter_image_version to OCP version
Summary: It is better to set default value for openshift_prometheus_node_exporter_imag...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.9.z
Assignee: Aaron Weitekamp
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-27 09:12 UTC by Junqi Zhao
Modified: 2018-05-17 11:39 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 06:43:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:44:07 UTC

Description Junqi Zhao 2018-03-27 09:12:04 UTC
Description of problem:
Default value for openshift_prometheus_node_exporter_image_version is v0.15.2, it is better to set as OCP version, since we release image such images to customer: prometheus-node-exporter:v3.9.

Found in stage registry today, prometheus-node-exporter:v3.9 image is pushed to stage repo, but prometheus-node-exporter:v0.15.2 won't push to stage repo, so the prometheus-node-exporter can not be started up.

If OCP version is v3.9, set openshift_prometheus_node_exporter_image_version=v3.9 as default version
if OCP version is v3.10, set to v3.10

I think we could change settings in roles/openshift_prometheus/vars/openshift-enterprise.yml
l_openshift_prometheus_node_exporter_image_version: "{{ openshift_prometheus_node_exporter_image_version | default(openshift_image_tag) }}"



Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-3.9.14-1.git.0.ca2cfc3.el7.noarch
openshift-ansible-roles-3.9.14-1.git.0.ca2cfc3.el7.noarch
openshift-ansible-docs-3.9.14-1.git.0.ca2cfc3.el7.noarch
openshift-ansible-playbooks-3.9.14-1.git.0.ca2cfc3.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Aaron Weitekamp 2018-03-27 13:44:37 UTC
I believe this is fixed with this PR: https://github.com/openshift/openshift-ansible/pull/7325

Comment 2 Scott Dodson 2018-03-27 14:02:12 UTC
https://github.com/openshift/openshift-ansible/pull/7673 to backport to release-3.9

Comment 3 Junqi Zhao 2018-03-29 02:00:26 UTC
Tested, issue is fixed with the fix in PR

Comment 4 Josep 'Pep' Turro Mauri 2018-04-06 08:03:07 UTC
This might be a duplicate of bug 1549936... the same fix is referenced there, although there's also an additional discussion about the image's tags themselves.

If we should keep this open to track the installer changes vs the other tracking the image tagging, I believe this should be VERIFIED instead based on comment #3.

Comment 6 Junqi Zhao 2018-04-17 00:55:56 UTC
openshift_prometheus_node_exporter_image_version now uses the openshift_image_tag

such as
image: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/prometheus-node-exporter:v3.9.22

env
# openshift version
openshift v3.9.22
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

# rpm -qa | grep openshift-ansible
openshift-ansible-3.9.22-1.git.0.2e15102.el7.noarch
openshift-ansible-roles-3.9.22-1.git.0.2e15102.el7.noarch
openshift-ansible-docs-3.9.22-1.git.0.2e15102.el7.noarch
openshift-ansible-playbooks-3.9.22-1.git.0.2e15102.el7.noarch

Comment 7 Junqi Zhao 2018-04-17 04:13:25 UTC
# openshift version
openshift v3.9.20
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

Tested with openshift_prometheus_node_exporter_image_version now uses the openshift_image_tag
image: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/prometheus-node-exporter:v3.9.20

# rpm -qa | grep openshift-ansible
openshift-ansible-playbooks-3.9.20-1.git.0.f99fb43.el7.noarch
openshift-ansible-3.9.20-1.git.0.f99fb43.el7.noarch
openshift-ansible-docs-3.9.20-1.git.0.f99fb43.el7.noarch
openshift-ansible-roles-3.9.20-1.git.0.f99fb43.el7.noarch

Comment 8 Junqi Zhao 2018-04-17 04:16:03 UTC
(In reply to Junqi Zhao from comment #7)

Change from
> Tested with openshift_prometheus_node_exporter_image_version now uses the
> openshift_image_tag
to

Tested with openshift-ansible-roles-3.9.20-1.git.0.f99fb43.el7.noarch, openshift_prometheus_node_exporter_image_version now uses the openshift_image_tag

Comment 10 Junqi Zhao 2018-04-20 02:18:04 UTC
# openshift version
openshift v3.9.24
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16


Tested with openshift_prometheus_node_exporter_image_version now uses the openshift_image_tag
image: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/prometheus-node-exporter:v3.9.24

# rpm -qa | grep openshift-ansible
openshift-ansible-playbooks-3.9.24-1.git.0.d0289ea.el7.noarch
openshift-ansible-docs-3.9.24-1.git.0.d0289ea.el7.noarch
openshift-ansible-roles-3.9.24-1.git.0.d0289ea.el7.noarch
openshift-ansible-3.9.24-1.git.0.d0289ea.el7.noarch

Comment 13 errata-xmlrpc 2018-05-17 06:43:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.