Bug 156105 - grep -Fw matches non-word
grep -Fw matches non-word
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grep (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-27 12:26 EDT by Gordon Lack
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 12:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Lack 2005-04-27 12:26:07 EDT
Description of problem:

  grep -Fw may find an incorrect match

Version-Release number of selected component (if applicable):

  grep-2.5.1-31

How reproducible:

   Every time.


Steps to Reproduce:
   Run grep -fW with 2 words to match, one which matches the end of a word and
the other teh start of the same word. But neither matches a whole word (well,
that seems to be the requirement).
  
Actual results:

   grep reports a match:


Expected results:

   grep should not report a match


Additional info:
   A specific example for grep built from the source rpm, with all patches applied.

my-system*[1] echo "LIN7C 55327" | ../grep-2.5.1a/src/grep -wF -e 5327 -e 5532 
LIN7C 55327


   This is grep-specific rather than FC3-specific.  Compiling the same code on
an Irix system produces the same error.
Comment 1 Tim Waugh 2005-04-27 12:59:33 EDT
Confirmed with 2.5.1-31.4.

This works fine in 2.5.1-48 from rawhide (Fedora Core development).

Note You need to log in before you can comment on or make changes to this bug.