Bug 1561115 - GDM hangs when ran on VESA (BIOS/nomodeset)
Summary: GDM hangs when ran on VESA (BIOS/nomodeset)
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 28
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2018-03-27 16:06 UTC by František Zatloukal
Modified: 2018-04-10 19:36 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-04-10 19:36:08 UTC
Type: Bug

Attachments (Terms of Use)
journalctl (674.75 KB, text/plain)
2018-03-27 16:08 UTC, František Zatloukal
no flags Details
lspci (1.55 KB, text/plain)
2018-03-27 16:08 UTC, František Zatloukal
no flags Details

Description František Zatloukal 2018-03-27 16:06:12 UTC
Description of problem:
I've tried booting Fedora with "nomodeset". GNOME failed to load (in BIOS mode, UEFI worked just fine) on one of two tested (bare metal) desktops.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot Fedora with nomodeset

Actual results:
After logging in, screen stays with grayish (gdm) background with no content.

Expected results:
GNOME should work with VESA driver.

Comment 1 František Zatloukal 2018-03-27 16:08:03 UTC
Created attachment 1413792 [details]

Comment 2 František Zatloukal 2018-03-27 16:08:27 UTC
Created attachment 1413793 [details]

Comment 3 Lukas Ruzicka 2018-04-04 12:15:28 UTC
I have tested today with the latest build (https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180403.n.0/compose/Everything/x86_64/iso/Fedora-Everything-netinst-x86_64-28-20180403.n.0.iso) and the installation was working on our bare metal. There were some blinking and glitching of the screen, but finally it was able to set up and display everything correctly.

Comment 4 Adam Jackson 2018-04-10 19:36:08 UTC
bře 27 16:20:54 localhost.localdomain gnome-shell[1319]: Failed to create backend: Could not find a primary drm kms device
bře 27 16:20:55 localhost.localdomain gnome-session[1275]: gnome-session-binary[1275]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1

This should be fixed in mesa 18.0.0-4.fc28.

Note You need to log in before you can comment on or make changes to this bug.