Bug 1561188 - [OSP13] Make HA services log in /var/log/containers like paunch-managed services
Summary: [OSP13] Make HA services log in /var/log/containers like paunch-managed services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Damien Ciabrini
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-27 20:46 UTC by Damien Ciabrini
Modified: 2018-06-27 13:50 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost puppet-tripleo-8.3.2-0.20180327181745.40b702f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:49:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 556294 None stable/queens: MERGED tripleo-heat-templates: Make HA containers log to /var/log/containers after upgrade (Icb311984104eac16cd391d75613517f62c... 2018-03-28 12:37:32 UTC
OpenStack gerrit 556470 None stable/queens: MERGED puppet-tripleo: Conventional log directories for pacemaker bundles (Id5760c16260de991ff95168c76186edc113752c8) 2018-03-28 12:37:25 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:50:26 UTC

Description Damien Ciabrini 2018-03-27 20:46:05 UTC
Description of problem:
In OSP12, services managed by pacemaker log by default under /var/log/pacemaker/bundles/{service}-{replica}

This is different from all other paunch-managed services, and make service log be split into sub-directories /var/log/pacemaker/bundles/{service}-* 

Moreover this is not consistent across pacemaker service, because some service forcibly log into other location.

Make the default logging of HA service belong under /var/log/containers like all other paunch-managed services.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy OSP12
2. Upgrade to OSP13
3.

Actual results:
logs are stored under /var/log/pacemaker/bundles/{service}-{replica}

Expected results:
New deployments should log under /var/log/containers/{service} 
Major upgrade should change the logging location to /var/log/containers/{service}

Additional info:
This bz track fixes in puppet-tripleo and tripleo-heat-templates

Comment 4 errata-xmlrpc 2018-06-27 13:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.