Bug 1561199 - [OSP13] Make HAProxy's stats socket accessible from the host
Summary: [OSP13] Make HAProxy's stats socket accessible from the host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Damien Ciabrini
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-27 21:01 UTC by Damien Ciabrini
Modified: 2018-06-27 13:50 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost puppet-tripleo-8.3.2-0.20180327181745.40b702f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:49:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 556833 None MERGED HAProxy: expose stats socket in HA containerized deployment 2020-06-12 03:15:08 UTC
OpenStack gerrit 557019 None MERGED HAProxy: expose stats socket in HA deployment after upgrade 2020-06-12 03:15:08 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:50:26 UTC

Description Damien Ciabrini 2018-03-27 21:01:45 UTC
Description of problem:
In non-containerized overcloud, we used to have access to HAProxy's stats socket, which allows to retrieve statistics about proxied traffic, current state of backends...

In OSP12, this stat socket is not exposed to the host because there is no bind mount configured at container creation.

This stats socket should be re-exposed in OSP13, and major upgrade from OSP12 to OSP13 should update the pacemaker bundles accordingly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy OSP12
2. Upgrade to OSP13
3.

Actual results:
no stats socket accessible from the host

Expected results:
stats socket should be available in /var/lib/haproxy/stats

Additional info:
this bz includes fixes for tripleo-heat-templates and and puppet-tripleo

Comment 3 Udi Shkalim 2018-05-01 20:18:27 UTC
Verified on OSP13 fresh deployment: 
openstack-tripleo-heat-templates-8.0.2-4.el7ost.noarch
puppet-tripleo-8.3.2-4.el7ost.noarch

docker inspect 189f240acf43
.
.
.

       "Mounts": [
            {
                "Type": "bind",
                "Source": "/var/lib/haproxy",
                "Destination": "/var/lib/haproxy",
                "Mode": "rw",
                "RW": true,
                "Propagation": "rprivate"

Comment 4 Marian Krcmarik 2018-05-13 19:50:35 UTC
Verified on upgraded deployment from OSP12 to OSP13.

[root@controller-0 heat-admin]# echo "show info;show stat" | nc -U /var/lib/haproxy/stats | wc -l
143
[root@controller-0 heat-admin]# hostname
controller-0
[root@controller-0 heat-admin]# echo "show info;show stat" | nc -U /var/lib/haproxy/stats | wc -l
143
[root@controller-0 heat-admin]# echo "show info;show stat" | nc -U /var/lib/haproxy/stats | tail -n5
swift_proxy_server,controller-0.storage.localdomain,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,10,2,21349,58,,1,20,1,,0,,2,0,,0,L7OK,200,1,,,,,,,0,,,,0,0,,,,,-1,OK,,0,0,0,0,
swift_proxy_server,controller-1.storage.localdomain,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,10,2,21371,50,,1,20,2,,0,,2,0,,0,L7OK,200,1,,,,,,,0,,,,0,0,,,,,-1,OK,,0,0,0,0,
swift_proxy_server,controller-2.storage.localdomain,0,0,0,0,,0,0,0,,0,,0,0,0,0,UP,1,1,0,10,2,21349,48,,1,20,3,,0,,2,0,,0,L7OK,200,1,,,,,,,0,,,,0,0,,,,,-1,OK,,0,0,0,0,
swift_proxy_server,BACKEND,0,0,0,0,410,0,0,0,0,0,,0,0,0,0,UP,3,3,0,,2,21371,24,,1,20,0,,0,,1,0,,0,,,,,,,,,,,,,,0,0,0,0,0,0,-1,,,0,0,0,0,

Comment 6 errata-xmlrpc 2018-06-27 13:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.