Bug 1561236 - Kubernetes Patch request - "CreateContainerConfigError: failed to prepare subPath for volumeMount" error with configMap volume
Summary: Kubernetes Patch request - "CreateContainerConfigError: failed to prepare sub...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Hemant Kumar
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-27 23:01 UTC by Greg Rodriguez II
Modified: 2018-04-30 04:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 04:00:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:1233 None None None 2018-04-30 04:01:03 UTC

Description Greg Rodriguez II 2018-03-27 23:01:27 UTC
Description of problem:
Site upgraded to 3.6.173.0.96 and are now experiencing issues with deployments showing a 'volumeMount subPath' in the config failed to replicate after a cluster-upgrade to 3.6.173.0.96 error.

Version-Release number of selected component (if applicable):
3.6.173.0.96

How reproducible:
Customer Verified

Steps to Reproduce:
More information found https://github.com/kubernetes/kubernetes/issues/61076

Actual results:
Kubernetes has resolved this issue with https://github.com/kubernetes/kubernetes/pull/61080 and customer wants to know how to get this implemented into OCP

Expected results:
Customer wants to know if fix can be added to OCP v3.6

Additional info:
https://github.com/kubernetes/kubernetes/issues/61076
https://github.com/kubernetes/kubernetes/issues/61076

OCP 3.6.173.0.96
KubeVers: 
GitVersion:"v1.6.1+5115d708d7"
GoVersion:"go1.7.6"

Comment 2 Hemant Kumar 2018-04-03 16:16:30 UTC
The fix was merged in OCP and it should be available in next build.

Comment 15 Liang Xia 2018-04-20 08:15:30 UTC
# oc version
oc v3.6.173.0.113
kubernetes v1.6.1+5115d708d7
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-lxia-36-master-nfs-1:8443
openshift v3.6.173.0.113
kubernetes v1.6.1+5115d708d7


# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)


# uname -a
Linux qe-lxia-36-master-nfs-1 3.10.0-514.26.1.el7.x86_64 #1 SMP Tue Jun 20
01:16:02 EDT 2017 x86_64 x86_64 x86_64 GNU/Linux


Pod with configMap volume using subpath can be up and running.

Moving bug to verified.

Comment 20 errata-xmlrpc 2018-04-30 04:00:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:1233


Note You need to log in before you can comment on or make changes to this bug.