Bug 1561284 - Fedora 28 Beta: No sound on ALC892 (Asus Xonar)
Summary: Fedora 28 Beta: No sound on ALC892 (Asus Xonar)
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 28
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2018-03-28 02:44 UTC by Richard Shaw
Modified: 2019-03-07 18:15 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-03-07 18:15:24 UTC
Type: Bug

Attachments (Terms of Use)

Description Richard Shaw 2018-03-28 02:44:47 UTC
Description of problem:
While testing 28 Beta from USB stick on my Fedora 27 desktop. I can see and configure my sound card but it does not produce sound. Looking at dmesg I get the following:

[   19.519317] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC892: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[   19.519320] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   19.519322] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   19.519323] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   19.519324] snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x11/0x1e
[   19.519329] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   19.519331] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[   19.519332] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[   19.519333] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a

Speaker outs is showing 0... I have run into this on my wife's laptop but only when rebooted from Windows to Fedora Linux without being completely shut down first. My desktop only runs Fedora.

Version-Release number of selected component (if applicable):

How reproducible:
Two boots, one from reboot from Fedora 27, once from a cold boot.

Steps to Reproduce:
1. Open gnome sound control panel
2. Change to correct audio device (CMI8788)
3. Try test sounds.

Actual results:
No audio

Expected results:
Audio plays back.

Comment 1 Richard Shaw 2018-03-28 12:55:17 UTC
Comparing dmesg output from F27 and F28 Beta 1.1 they look the same so that's not it....

From my working F27 system:

# lspci -vvv -s 03:06.0
03:06.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
        Subsystem: ASUSTeK Computer Inc. CMI8786 (Xonar DG)
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32 (500ns min, 6000ns max)
        Interrupt: pin A routed to IRQ 20
        Region 0: I/O ports at d000 [size=256]
        Capabilities: [c0] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: snd_oxygen
        Kernel modules: snd_oxygen

Comment 2 Richard Shaw 2018-04-04 12:09:09 UTC
Tried with Fedora 28 Beta but still no luck. Pulled up alsamixer and the audio defaulted to the headphone jack but the Gnome Control Panel quite clearly was set to 5.1 analog out. Switching it in alsa mixer fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.