Bug 1561323 - [RFE] tcmu-runner: introduce the dynamic reloading config feature support
Summary: [RFE] tcmu-runner: introduce the dynamic reloading config feature support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tcmu-runner
Version: cns-3.9
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: OCS 3.11
Assignee: Xiubo Li
QA Contact: Rachael
URL:
Whiteboard:
Depends On:
Blocks: 1632821
TreeView+ depends on / blocked
 
Reported: 2018-03-28 06:08 UTC by Xiubo Li
Modified: 2018-10-24 04:54 UTC (History)
9 users (show)

Fixed In Version: tcmu-runner-1.2.0-25.el7rhgs
Doc Type: Enhancement
Doc Text:
Updates to the tcmu-runner configuration file are now applied automatically, removing the need to restart the tcmu-runner daemon when any configuration changes are made.
Clone Of:
Environment:
Last Closed: 2018-10-24 04:52:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2987 None None None 2018-10-24 04:54:38 UTC

Description Xiubo Li 2018-03-28 06:08:43 UTC
Description of problem:

For now if we want to change the configuration of the tcmu-runner daemon, we have to reboot the tcmu-runner daemon after that to make it work.

After the dynamic reloading config feature is support, no reboot is needed any more.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Xiubo Li 2018-03-28 06:11:27 UTC
The upstream patches are here: https://github.com/open-iscsi/tcmu-runner/pull/176

Comment 17 Anjana KD 2018-10-11 07:01:23 UTC
Updated the Doc text field. Kindly review

Comment 19 Anjana KD 2018-10-12 06:10:15 UTC
updated the changes.

Comment 21 errata-xmlrpc 2018-10-24 04:52:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2987


Note You need to log in before you can comment on or make changes to this bug.