Bug 1561332 - merge ssl infra with epoll infra
Summary: merge ssl infra with epoll infra
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milind Changire
QA Contact:
URL:
Whiteboard:
: 1408101 (view as bug list)
Depends On:
Blocks: 1408104 1654549
TreeView+ depends on / blocked
 
Reported: 2018-03-28 06:49 UTC by Milind Changire
Modified: 2019-11-25 12:50 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1654549 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Milind Changire 2018-03-28 06:49:11 UTC
Description of problem:
SSL infra spawns a thread per client. This poses a performance problem when multiple fops are to be processed concurrently.

Expected results:
SSL infra should piggy back on the regular epoll infra for better performance and scalability.

Comment 1 Worker Ant 2018-03-28 07:09:27 UTC
REVIEW: https://review.gluster.org/19308 (rpc: merge ssl infra with epoll infra) posted (#7) for review on master by Milind Changire

Comment 2 Worker Ant 2018-03-28 13:04:26 UTC
REVIEW: https://review.gluster.org/19786 (rpc: merge ssl infra with epoll infra - DO NOT MERGE) posted (#2) for review on master by Milind Changire

Comment 3 Worker Ant 2018-07-27 08:59:38 UTC
COMMIT: https://review.gluster.org/19308 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- rpc: merge ssl infra with epoll infra

Patch attempts to use the epoll infra for handling SSL connections
as well instead of the socket_poller() thread func.
This essentially makes priv->own_thread flag redundant.

SSL_connect()/SSL_accept() is now non-blocking which has done away
with the localised poll() in ssl_do(). So, ssl_do() has been updated
appropriately.

own_thread and coincidently socket_poller() thread for SSL processing
is now deprecated.

Change-Id: I1ce54c06ddb643c16baa143598e7e4fbf16bae0a
fixes: bz#1561332
Signed-off-by: Milind Changire <mchangir@redhat.com>

Comment 4 Shyamsundar 2018-10-23 15:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 5 Raghavendra G 2019-11-25 12:50:52 UTC
*** Bug 1408101 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.