Bug 1561544 - Splitstack deployment fails due to the bug in get-occ-config.sh script
Summary: Splitstack deployment fails due to the bug in get-occ-config.sh script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-28 14:08 UTC by Gurenko Alex
Modified: 2018-06-27 13:50 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213844.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:49:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1759581 None None None 2018-03-28 14:12:34 UTC
OpenStack gerrit 558242 'None' 'MERGED' 'get-occ-config.sh: fix handling multiple nodes in a role' 2019-11-25 19:18:18 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:50:26 UTC

Description Gurenko Alex 2018-03-28 14:08:30 UTC
Description of problem: when get-occ-config.sh script runs, it only updates first node and exits with rc 0.


Version-Release number of selected component (if applicable): OSP13


How reproducible: 100%


Steps to Reproduce:
1. Follow split stack deployment path
2. run heat-admin.sh that triggers get-occ-config.sh
3. start overcloud_deploy.sh

Actual results: Deployment fails with a timeout


Expected results: Deployment succeed


Additional info:

get-occ-config.sh contains ((i++)) at line 160 and needs to be reverted to i+=1 which was introduced by following commit: https://code.engineering.redhat.com/gerrit/gitweb?p=openstack-tripleo-heat-templates.git;a=commitdiff;h=f17b0a14dad89fdb0594457b602d4ca183b230d7

Comment 1 James Slagle 2018-03-28 14:21:06 UTC
sample log:
https://pastebin.com/kn6Q8TSJ

notice how the script just exits after ((i++)) even though there were multiple stacks in the $stacks var.

This is because the bash expression ((i++)) evaluates to 0, so returns 1, causing the script to exit.

We need to revert this line back to let i+=1

Comment 6 Gurenko Alex 2018-04-11 11:45:38 UTC
[stack@undercloud-0 ~]$ cat core_puddle_version
2018-04-10.2
[stack@undercloud-0 ~]$ rpm -q openstack-tripleo-heat-templates
openstack-tripleo-heat-templates-8.0.2-0.20180327213846.el7ost.noarch

Comment 8 errata-xmlrpc 2018-06-27 13:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.