Bug 156156 - cman uses deprecated initlog() function
cman uses deprecated initlog() function
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cman (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam "mantis" Manthei
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-04-27 19:55 EDT by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 21:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-04-27 19:55:08 EDT
Description of problem:
/sbin/service cman restart
Stopping cman:                                             [  OK  ]
Starting cman:WARNING: initlog is deprecated and will be removed in a future release
                                                           [FAILED]
cman-1.0-0.pre33.2

probably should try to replace the use of initlog before fc4 lands, since its
deprecated.


-jef
Comment 1 Lon Hohberger 2005-04-28 11:43:08 EDT
Note: rgmanager calls initlog in a "oracleas" script which currently is not
tested/supported.
Comment 2 Alexandre Oliva 2005-05-05 00:47:58 EDT
It's actually worse: starting cman within rhgb, you get an ugly error message
from glibc about free()ing an invalid address.
Comment 3 Adam "mantis" Manthei 2005-05-20 12:14:06 EDT
the reason that cman failed to start was because 
"/etc/cluster/cluster.conf was not detected"

initlog has nothing to do with the failure here

changing initlog() to an echo for now.
Comment 4 Adam "mantis" Manthei 2005-05-20 12:15:09 EDT
Fix commited:

Checking in cman;
/cvs/cluster/cluster/cman/init.d/cman,v  <--  cman
new revision: 1.1.2.10.4.1; previous revision: 1.1.2.10
done
Comment 5 Alexandre Oliva 2005-05-20 14:51:32 EDT
I think the problem this report was about was not such much that it failed to
start (it shouldn't even try to start by default), but rather that it uses
initlog, that not only was deprecated, but also triggered sanity checks in glibc.
Comment 6 Adam "mantis" Manthei 2005-05-22 22:52:07 EDT
The original summary was:
   "cman service fails with warning message about initlog being deprecated" 	

The issue that I fixed, and what I believe the issue that was trying to be
addressed by the bug is reperestend by the new summary:
   "cman uses deprecated initlog() function"

The cman init script no longer uses initlog().  This makes the deprecated
warning go away, hence why this bug is in the MODIFIED state.

cman failing to start is either a configuration error or some other issue that
may need to be looked into and given it's own bug.

The opinion that cman shouldn't start has nothing to do with this bug and has
already been addressed by bug #156410.

If starting cman still produces "an ugly error message" when starting from
within rhgb, then that is an issue that should be addressed in its own bug.
Comment 7 Alexandre Oliva 2005-05-23 09:46:35 EDT
Yep, since the use of initlog is removed, the bug can probably be closed. 
Oddly, logging into bugzilla with my non-Red Hat identity, I can't do anything
other than leaving the bug in MODIFIED state.
Comment 8 Alexandre Oliva 2005-05-23 09:49:05 EDT
That said, I still see initlog in /etc/init.d/cman, as of yesterday's rawhide,
and there isn't any update to this package in today's rawhide.  Maybe it needs
to be built, or moved to the dist that will make to FC4.
Comment 9 Jef Spaleta 2005-09-06 21:23:03 EDT
I'm closing this bug since cman has been removed from rawhide as of 2005-09-03

Note You need to log in before you can comment on or make changes to this bug.