Bug 1561680 - [GSS] LVM archives on gluster pod fill up root directory.
Summary: [GSS] LVM archives on gluster pod fill up root directory.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: CNS 3.10
Assignee: Niels de Vos
QA Contact: vinutha
URL:
Whiteboard:
: 1638888 (view as bug list)
Depends On:
Blocks: 1568861 1573420 1638888 OCS-3.11.1-devel-triage-done 1642792
TreeView+ depends on / blocked
 
Reported: 2018-03-28 17:02 UTC by Cal Calhoun
Modified: 2019-11-08 19:32 UTC (History)
17 users (show)

Fixed In Version: heketi-6.0.0-14.el7rhgs
Doc Type: Bug Fix
Doc Text:
Previously, when PVCs were created/deleted in environments that are managed by Heketi, the LVM-metadata backups resulted in large storage consumption under /etc/lvm/archive which resulted in the filesystem running out of space. With this fix, Heketi no longer creates backups of LVM-metadata by default. This configuration can be changed by editing the `backup_lvm_metadata: true` variable in the heketi.json configuration file.
Clone Of:
Environment:
Last Closed: 2018-09-12 09:22:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github heketi heketi pull 1187 0 None closed executors: do not create backups in /etc/lvm/archive by default 2020-09-24 18:21:22 UTC
Red Hat Product Errata RHEA-2018:2686 0 None None None 2018-09-12 09:23:14 UTC

Comment 3 Niels de Vos 2018-05-17 16:49:42 UTC
There is very little use of the lvm archives for actions that heketi does. Users are not expected to need to restore a VG/LV, they would rather replace the brick and have Gluster repair/heal the data.

We can prevent creating the lvm archive by passing --autobackup=n to vgcreate/lvcreate.

Comment 13 Anjana KD 2018-08-30 13:52:22 UTC
Updated doc text in the Doc Text field. Please review for technical accuracy.

Comment 14 John Mulligan 2018-09-07 18:29:36 UTC
Doc Text looks OK

Comment 16 errata-xmlrpc 2018-09-12 09:22:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2686

Comment 17 Raghavendra Talur 2019-11-08 19:32:11 UTC
*** Bug 1638888 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.