Bug 1561864 - Keyboard layout selected during anaconda is ignored
Summary: Keyboard layout selected during anaconda is ignored
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-initial-setup
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Catanzaro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker https://fedoraproject...
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-03-29 05:07 UTC by Alessio
Modified: 2018-05-15 04:12 UTC (History)
13 users (show)

Fixed In Version: gnome-initial-setup-3.28.0-5.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-11 17:51:50 UTC


Attachments (Terms of Use)
french keyboard input is working (45.80 KB, image/png)
2018-05-04 09:54 UTC, Satyabrata Maitra
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 794166 None None None 2019-04-26 05:55:41 UTC

Description Alessio 2018-03-29 05:07:35 UTC
Description of problem:

Fedora Workstation
After installation, configuring an online account, i.e. google, the keyboard layout seems to be still English US, even if during anaconda setup I choose my language.

Comment 1 Adam Williamson 2018-03-29 22:02:30 UTC
I suspect this is related to https://fedoraproject.org/wiki/Changes/ReduceInitialSetupRedundancy ; does suppressing the keyboard layout screen actually prevent g-i-s from reading and applying the keyboard layout configured by GNOME to *itself*?

Comment 2 Adam Williamson 2018-03-29 22:02:43 UTC
sigh, I meant 'configured by anaconda'.

Comment 3 Michael Catanzaro 2018-03-29 22:14:45 UTC
I don't think so... will investigate.

Comment 4 Remi Collet 2018-03-30 10:04:54 UTC
Same issue.

More annoying, when installing from the Live Workstation, bad layout is used during user creation (name/password)

result => unusable installation.

Comment 5 Michael Catanzaro 2018-03-30 14:54:54 UTC
I promise to investigate. :) And activate the contingency plan to revert to the old behavior if needed. (Probably the problem will be easy, and that won't be needed.)

Comment 6 Axel Sommerfeldt 2018-03-30 18:49:46 UTC
I can confirm this bug (trying out F28 Beta 1.3). This happened both on real hardware and on a VM (VirtualBox). My keyboard layout is German but the user password was set with US keyboard layout.

IMHO this clearly breaks the Basic Release Criteria "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system." since the mechanism is not working unless you are using a US keyboard layout anyway.

(Unfortunately the GO decision was yesterday, looks like a Beta blocker for me)

Comment 7 Adam Williamson 2018-03-31 00:30:00 UTC
We actually have explicit keyboard layout criteria, but that is Final, not Beta. https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria#Keyboard_layout_configuration

Comment 8 Michael Catanzaro 2018-03-31 15:17:35 UTC
I believe the patch Peng Wu posted yesterday will fix this. It works for me when I muck with my locale settings to simulate a fresh install and then manually run gnome-initial-setup. Of course, that's no substitute for testing an install from a fresh ISO image. I'm going to do a new build and prepare a Bodhi update....

Comment 9 Axel Sommerfeldt 2018-03-31 15:22:16 UTC
So if an American citizen cannot login right after install, it's a Beta blocker. (Basic Release Criteria)

But if a German citizen cannot login right after install, it's not. (Keyboard layout criteria)

If this is the case you IMHO need to change the keyboard layout criteria. (And it still makes me speechless.)

Comment 10 Michael Catanzaro 2018-03-31 15:25:21 UTC
(In reply to Axel Sommerfeldt from comment #6)
> I can confirm this bug (trying out F28 Beta 1.3). This happened both on real
> hardware and on a VM (VirtualBox). My keyboard layout is German but the user
> password was set with US keyboard layout.

As a temporary workaround, you can install the beta release with the netinstall ISO, which allows you to set up your user account in anaconda using the keyboard layout configured in anaconda.

Comment 11 Michael Catanzaro 2018-03-31 15:28:45 UTC
(In reply to Axel Sommerfeldt from comment #9)
> So if an American citizen cannot login right after install, it's a Beta
> blocker. (Basic Release Criteria)
> 
> But if a German citizen cannot login right after install, it's not.
> (Keyboard layout criteria)
> 
> If this is the case you IMHO need to change the keyboard layout criteria.
> (And it still makes me speechless.)

Nobody noticed this bug until the day of the go/nogo decision, and it was not proposed as a blocker until the day after. It wouldn't matter if initial setup was gone and replaced with a picture of a cow: the decision to release has already been made. Sorry for the inconvenience, and please note the workaround above.

Comment 12 Fedora Update System 2018-03-31 17:44:11 UTC
gnome-initial-setup-3.28.0-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39587c6b32

Comment 13 Fedora Update System 2018-03-31 18:06:43 UTC
gnome-initial-setup-3.28.0-4.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39587c6b32

Comment 14 Fedora Update System 2018-04-01 04:59:13 UTC
gnome-initial-setup-3.28.0-4.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-39587c6b32

Comment 15 Michael Catanzaro 2018-04-01 15:19:46 UTC
Adam, can you please let us know when there are new installation images available for testing this?

Comment 16 Alessio 2018-04-01 15:33:38 UTC
Hello. I built an ISO with livecd-creator and setting up a local repository with the gnome-initial-setup-3.28.0-4.fc28 rpm.
As far I can see, it seems to work.

Comment 17 Geoffrey Marr 2018-04-02 17:17:24 UTC
Discussed during the 2018-04-02 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria:

"If a particular keyboard layout has been configured for the system, that keyboard layout must be used: ... When logging in via the default login manager for a release-blocking desktop"

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-04-02/f28-blocker-review.2018-04-02-16.00.txt

Comment 18 Fedora Update System 2018-04-02 22:58:36 UTC
gnome-initial-setup-3.28.0-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39587c6b32

Comment 19 Fedora Update System 2018-04-03 15:56:36 UTC
gnome-initial-setup-3.28.0-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-39587c6b32

Comment 20 Fedora Update System 2018-04-05 11:47:19 UTC
gnome-initial-setup-3.28.0-5.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Kamil Páral 2018-04-11 09:49:04 UTC
Can somebody please test this with latest Live?

Comment 22 Alessio 2018-04-11 11:29:15 UTC
(In reply to Kamil Páral from comment #21)
> Can somebody please test this with latest Live?

Do you mean Fedora-Workstation-Live-x86_64-28-20180410.n.1.iso?

Comment 23 Alessio 2018-04-11 15:42:25 UTC
Fedora-Workstation-Live-x86_64-28-20180410.n.1.iso works for me

Comment 24 Adam Williamson 2018-04-11 17:51:50 UTC
Thanks for confirming.

Comment 25 Lukas Ruzicka 2018-04-12 11:09:26 UTC
Hello,

I can also confirm that discussed problem seems to be settled. I tried with Fedora-Workstation-Live-x86_64-28-20180410.n.1.iso and tried to install the German version.
This chose the German keyboard for me as a default solution and and I was also allowed to use that layout for creating a password. I was able to log in after the system has been installed and deployed yesterday.

Take care.
Lukas

Comment 26 Axel Sommerfeldt 2018-04-13 13:38:14 UTC
I can confirm that the problem is fixed using Fedora-Workstation-Live-x86_64-28-20180412.n.0.iso, too. (Keyboard layout used: German)

Comment 27 Satyabrata Maitra 2018-05-04 09:49:14 UTC
Tested this bug for French(fr_FR) locale.
Working as expected with fr(oss) keyboard. 
Screen shot attached below.

Comment 28 Satyabrata Maitra 2018-05-04 09:54:32 UTC
Created attachment 1431189 [details]
french keyboard input is working

typed "satyamaitra" using en_US keyboard in username text box while creating google account, post installation.

keyboard layout using fr (oss) taken as shown in the screen shot.

This bug is fixed as of now in F28 GOLD.

Version of the component tested the fix : gnome-initial-setup-3.28.0-6.fc28

Comment 29 Lijun Li 2018-05-15 04:12:36 UTC
Verified it's fixed for zh_CN with F28 GOLD build.


Note You need to log in before you can comment on or make changes to this bug.