Bug 1561935 - SSH access to the amphoras should be possible after deployment
Summary: SSH access to the amphoras should be possible after deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 13.0 (Queens)
Assignee: Carlos Goncalves
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
: 1576425 (view as bug list)
Depends On: 1576425
Blocks: 1433523
TreeView+ depends on / blocked
 
Reported: 2018-03-29 08:45 UTC by Alexander Stafeyev
Modified: 2019-09-10 14:08 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-common-8.6.1-11.el7ost openstack-tripleo-heat-templates-8.0.2-19.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:49:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 560879 None master: MERGED tripleo-heat-templates: Define Octavia SSH key name and file path (I80aa324254e6837e8d3c39e9d05a5e152783f0bb) 2018-05-09 16:10:19 UTC
OpenStack gerrit 560880 None master: MERGED tripleo-common: Create keypair for SSH access to Octavia amphorae (I3b2e283f6fa081b07cc12a244c14701e431d884e) 2018-05-09 16:10:13 UTC
OpenStack gerrit 565213 None stable/queens: MERGED tripleo-heat-templates: Define Octavia SSH key name and file path (I80aa324254e6837e8d3c39e9d05a5e152783f0bb) 2018-05-09 16:10:07 UTC
OpenStack gerrit 565528 None stable/queens: MERGED tripleo-common: Create keypair for SSH access to Octavia amphorae (I3b2e283f6fa081b07cc12a244c14701e431d884e) 2018-05-09 16:10:00 UTC
OpenStack gerrit 566036 None master: MERGED tripleo-heat-templates: Fix case-sensitive OctaviaUserName parameter (I89057ec906f5ccd36981bf01a419c7ca8ba502e5) 2018-05-09 16:09:55 UTC
OpenStack gerrit 566386 None stable/queens: MERGED tripleo-heat-templates: Fix case-sensitive OctaviaUserName parameter (I89057ec906f5ccd36981bf01a419c7ca8ba502e5) 2018-05-09 16:09:49 UTC
OpenStack gerrit 567205 None master: NEW tripleo-common: Fix syntax error in octavia-undercloud role (I0026343d90b84572c3002fa21001cfb09c742391) 2018-05-09 16:09:42 UTC
OpenStack gerrit 568022 None None None 2018-05-12 20:53:30 UTC
OpenStack gerrit 568394 None None None 2018-05-15 07:52:17 UTC
OpenStack gerrit 568395 None None None 2018-05-15 07:52:45 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:50:26 UTC

Description Alexander Stafeyev 2018-03-29 08:45:42 UTC
This is a semi-tracker bug. 

At this moment our deployment are not passing keys into the amphora for ssh access. 

We do need those there for debugging and SOS reports.

Comment 2 Nir Magnezi 2018-04-11 13:41:27 UTC
For this bug we would need TripleO to:
1. Undercloud: Generate SSH keypair.
2. Overcloud: Upload to the overcloud Nova
3. Configure octavia.conf https://github.com/openstack/octavia/blob/ec2ecdc2b170f2949c8762bf93166ba93fe53f46/etc/octavia.conf#L205

We would also need to document the private SSH key path in the Undercloud

Comment 3 Carlos Goncalves 2018-04-11 16:37:43 UTC
Reassigning to myself. It will need to be addressed in tripleo-common.

Comment 11 Carlos Goncalves 2018-05-14 07:50:32 UTC
*** Bug 1576425 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2018-06-27 13:49:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.