Bug 1561990 - UI: After add the CV on the CCV, Content View still on the list to add [NEEDINFO]
Summary: UI: After add the CV on the CCV, Content View still on the list to add
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Views
Version: 6.3.0
Hardware: All
OS: All
unspecified
high vote
Target Milestone: Released
Assignee: Samir Jha
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-29 10:07 UTC by Waldirio M Pinheiro
Modified: 2019-10-07 17:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:37:00 UTC
jpathan: needinfo? (sajha)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:37:12 UTC
Foreman Issue Tracker 23120 None None None 2018-04-04 13:51:08 UTC

Description Waldirio M Pinheiro 2018-03-29 10:07:54 UTC
Description of problem:
When creating one Composite Content View, after select the CV and click on the *Add Content Views button*, the same CV still on the list to add. If we jump to another tab *List/Remove* we will see the CV there, if we come back to the Add tab, the same still there.

Version-Release number of selected component (if applicable):
6.3

How reproducible:
100%

Steps to Reproduce:
1. Create a new CV
2. Create a new CCV
3. Add the CV in CCV
4. Check if the CV will be on both list/tabs *List/Remove* and *Add*

Actual results:
Showing the CV in both

Expected results:
Should show the CV only on the *List/Remove* tab. For sure, after added.

Additional info:

Comment 1 Brad Buckingham 2018-04-03 19:37:34 UTC
I was able to reproduce this using the following:

Scenario:
- create component content view 1, add 'repo 1', publish a version
- create component content view 2, add 'repo 1', publish a version
- create composite content view
- add component content view 1 - CV is not shown in both 'List/Remove' & 'Add'
- add component content view 2 - CV is shown in both 'List/Remove' and 'Add'

This appears to occur when components share the same repository.

Comment 4 Samir Jha 2018-04-04 13:51:07 UTC
Created redmine issue http://projects.theforeman.org/issues/23120 from this bug

Comment 5 pm-sat@redhat.com 2018-05-21 20:20:02 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23120 has been resolved.

Comment 7 Jameer Pathan 2018-11-05 13:12:54 UTC
needinfo 

I tried to verify issue and this is what i have observed:

steps:
1. crate CV
2. create CCV
3. add CV to CCV
4. CV is shown only in 'List/Remove' tab
5. remove CV from 'List/Remove' tab
6. CV got removed from 'List/Remove' tab but did not appeared in 'Add' tab.

should I mark this as failed QA because CV got removed from 'List/Remove' tab but did not appeared in 'Add' tab.

Comment 8 Jameer Pathan 2018-11-21 06:12:53 UTC
@satellite 6.5.0 snap 3

Comment 10 Lai 2018-11-28 20:42:49 UTC
Verification steps:

1. Create CV
2. Create CCV
3. Add CV to CCV
4. Check "List/Remove" tab and "Add" tab

Verified that the added CV appears only in "List/Removed" tab and not in "Add" tab.

I got the same result even after adding a repo in CV and publishing both CV and CCV.

Verified on snap 6.5.0_5.0

Comment 13 errata-xmlrpc 2019-05-14 12:37:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.