Bug 1562247 - remove rbd checker from multipath-tools
Summary: remove rbd checker from multipath-tools
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Lin Li
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1562248
TreeView+ depends on / blocked
 
Reported: 2018-03-29 21:20 UTC by Mike Christie
Modified: 2018-10-30 11:28 UTC (History)
7 users (show)

(edit)
undefined
Clone Of:
: 1562248 (view as bug list)
(edit)
Last Closed: 2018-10-30 11:27:28 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3236 None None None 2018-10-30 11:28 UTC

Description Mike Christie 2018-03-29 21:20:04 UTC
Description of problem:

The rbd checker in multipath tools is no longer used be RHCS and upstream.

It's use when used with lio and krbd's exclusive lock can lead to data corruption, and the ceph team has gone a different way using lio and tcmu-runner.

This is a request to drop it from multipath-tools.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Patch will be sent upstream and a link will be added.

Comment 2 Ben Marzinski 2018-06-13 21:52:47 UTC
Removed.

Comment 4 Lin Li 2018-07-27 08:02:35 UTC
Reproduced on device-mapper-multipath-0.4.9-111.el7
[root@storageqe-06 ~]# rpm -qa | grep multipath
device-mapper-multipath-0.4.9-111.el7.x86_64
device-mapper-multipath-libs-0.4.9-111.el7.x86_64


[root@storageqe-06 ~]# man multipath.conf
path_checker
              rbd         Check if the path is in the
                                    Ceph blacklist.


Verified on device-mapper-multipath-0.4.9-121.el7
[root@storageqe-06 ~]# rpm -qa | grep multipath
device-mapper-multipath-0.4.9-121.el7.x86_64
device-mapper-multipath-libs-0.4.9-121.el7.x86_64

[root@storageqe-06 ~]# man multipath.conf
path_checker
<---------------------removed rbd checker

Comment 6 errata-xmlrpc 2018-10-30 11:27:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3236


Note You need to log in before you can comment on or make changes to this bug.