Bug 1562276 - 'Input Method Selector' doesn't show up in KDE applications menu
Summary: 'Input Method Selector' doesn't show up in KDE applications menu
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: im-chooser
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-30 00:48 UTC by Bill Crawford
Modified: 2018-11-30 20:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 20:50:16 UTC


Attachments (Terms of Use)
screenshot (68.32 KB, image/png)
2018-04-02 08:51 UTC, Akira TAGOH
no flags Details

Description Bill Crawford 2018-03-30 00:48:40 UTC
Description of problem:
Not visible

Version-Release number of selected component (if applicable):
1.7.1-1.fc27

How reproducible:
Look in menu

Steps to Reproduce:
1. Click on applications menu
2. Look in Settings
3. Don't find this

Actual results:
... you get the idea

Expected results:
As the .desktop file contains 'NotShowIn=XFCE;' I would have expected it to show up in the KDE menu.

Additional info:
Yes, I am aware that there's a kcm for "fcitx", however a lot of the instructions on the lazywebs for enabling (e.g.) Japanese input seem based around using im-chooser (and ibus), and the KDE config module seems to expect fcitx to already be running, rather than offering a way to configure it to start with the session.

Comment 1 Akira TAGOH 2018-03-30 09:55:12 UTC
Can you see any logs when you run im-chooser on konsole say?

Comment 2 Akira TAGOH 2018-04-02 08:51:50 UTC
Created attachment 1416132 [details]
screenshot

Well, I tried to reproduce this but couldn't. once I got im-chooser installed (on f27 KDE Live, it isn't available there by default), I can see "Input Method Selector" under KDE Menu->Applications->Settings.

Comment 3 Bill Crawford 2018-04-04 01:33:27 UTC
I can run it from the command line, but I expected to find it in the Settings menu. It's not there. If I remove "X-GNOME-PersonalSettings;" from the Categories line, it shows up.

It also shows up if I *search* using the search box once I've opened the menu.

This is Application Menu, not an alternative.

Honestly, I don't actually care whether it's "im-chooser", or someone comes up with a KDE version, as long as it appears in that menu with the same description, because almost all the instructions I found using Google mention this (and are generally quite GNOME-centric, but at least if this shows up in the menu, people can find it!).

Are you sure you aren't seeing the fcitx configuration menu entry? It's called "Input Method Configuration", and it doesn't work unless fcitx is already running, which didn't help :o)

Requested info: yes, I see one line of output when I run it in a konsole:

    Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

Comment 4 Akira TAGOH 2018-04-04 02:59:50 UTC
Another possibility is that KDE may changed their mind to follow up the GNOME's behavior about the desktop entries. it may be likely if you can also see the menu on KDE Live as I attached and package version is different to what you have.

Comment 5 Ben Cotton 2018-11-27 16:18:53 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Ben Cotton 2018-11-30 20:50:16 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.