Bug 1562279 - [trello XzkI9of3] It is better to make 'create an image pull secret' cannot be clicked given no project
Summary: [trello XzkI9of3] It is better to make 'create an image pull secret' cannot b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.10.0
Assignee: Steve Goodwin
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-30 01:56 UTC by Xingxing Xia
Modified: 2018-07-30 19:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:11:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:12:11 UTC

Description Xingxing Xia 2018-03-30 01:56:18 UTC
Description of problem:
Now that user has no project, secret has nowhere to create, thus it is better to make 'create an image pull secret' cannot be clicked in such case.

Version-Release number of selected component (if applicable):
v3.10.0-0.15.0

How reproducible:
Always

Steps to Reproduce:
1. Given user has no project, login to web, click 'Deploy Image', check the 'create an image pull secret' link under 'Image Name' radio button

Actual results:
1. The 'create an image pull secret' link can be clicked, in its dialog user can do input and click 'Create'. But this will cause error notification of 'Unknown resource: secrets/v1' on the upper right corner.

Expected results:
1. It is better to make 'create an image pull secret' cannot be clicked given no project

Additional info:

Comment 1 openshift-github-bot 2018-04-04 17:45:33 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/3b25dfe5030e77beb920be889a6ff65a9229128d
Merge pull request #2936 from sg00dwin/image-pull-secret-bug1562279

Remove link to create an image pull secret when Image Name search is disabled.

Comment 2 Xingxing Xia 2018-04-10 01:24:10 UTC
Issue fixed in 'OpenShift Web Console: v3.10.0-0.16.0' env, now the link is disabled given no project. Pls move to ON_QA, thx

Comment 4 errata-xmlrpc 2018-07-30 19:11:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.