Bug 1562413 - httpd-2.4.33-1 fails to start unless mod_md is installed
Summary: httpd-2.4.33-1 fails to start unless mod_md is installed
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Luboš Uhliarik ✈
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-30 15:38 UTC by Adam Williamson
Modified: 2018-03-31 15:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-31 15:21:07 UTC


Attachments (Terms of Use)

Description Adam Williamson 2018-03-30 15:38:39 UTC
The config file for mod_md appears to be shipped in httpd itself:

[adamw@xps13k tmp]$ sudo dnf repoquery --releasever=rawhide -f /etc/httpd/conf.modules.d/01-md.conf
Last metadata expiration check: 0:00:00 ago on Fri 30 Mar 2018 08:23:17 AM PDT.
httpd-0:2.4.33-1.fc29.x86_64
mod_md-0:2.4.33-1.fc29.x86_64

Consequently, if httpd is installed but mod_md is not, httpd fails to start with an error like:

Mar 29 22:15:47 ipa001.domain.local httpd[30957]: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.modules.d/01-md.conf: Cannot load modules/mod_md.so into server: /etc/httpd/modules/mod_md.so: cannot open shared object file: No such file or directory
Mar 29 22:15:47 ipa001.domain.local systemd[1]: httpd.service: Main process exited, code=exited, status=1/FAILURE
Mar 29 22:15:47 ipa001.domain.local systemd[1]: httpd.service: Failed with result 'exit-code'.
Mar 29 22:15:47 ipa001.domain.local systemd[1]: Failed to start The Apache HTTP Server.

I believe this also affects the updates submitted for F26, F27 and F28. Confirming that now.

Comment 1 Adam Williamson 2018-03-30 15:42:50 UTC
Confirmed: https://openqa.stg.fedoraproject.org/tests/270796

Comment 2 Adam Williamson 2018-03-31 00:32:03 UTC
Welp, since this is easy to fix and I've got nothing else to do for an hour, I'm fixing it. Builds for f26/f27/f28/rawhide are in flight.

Comment 3 Joe Orton 2018-03-31 11:08:54 UTC
Thanks Adam!

Comment 4 Adam Williamson 2018-03-31 15:21:07 UTC
I'm gonna go ahead and close this, as it's fixed for Rawhide now, and the broken build is gone from F26/F27/F28 (it was only in u-t and I edited the updates with the fixed build, so no-one should hit the broken build any more).

No problem, Joe! Easy thing to overlook, I know. Just in case you find it useful - I've whitelisted httpd for openQA update testing now; the 'server' update tests will run for it from now on, if any of the FreeIPA tests fails, it might indicate a bug in httpd. You can see the results on the 'Automated Tests' tab in Bodhi.


Note You need to log in before you can comment on or make changes to this bug.