Bug 1562423 - SAN in internal SSL server certificate in pkispawn configuration step
Summary: SAN in internal SSL server certificate in pkispawn configuration step
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core
Version: 7.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 7.6
Assignee: Christina Fu
QA Contact: Asha Akkiangady
Marc Muehlfeld
URL:
Whiteboard:
Keywords: TestCaseProvided, ZStream
Depends On:
Blocks: 1581135
TreeView+ depends on / blocked
 
Reported: 2018-03-30 16:40 UTC by Marc Sauton
Modified: 2018-10-30 11:06 UTC (History)
3 users (show)

(edit)
Certificate System now adds the SAN extension to server certificates

With this update, Certificate System adds the Subject Alternative Name (SAN) extension by default to server certificates and sets it to the Common Name (CN) of the certificate.
Clone Of:
: 1581135 (view as bug list)
(edit)
Last Closed: 2018-10-30 11:05:27 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3195 None None None 2018-10-30 11:06 UTC
Fedora Pagure 2979 None None None 2018-03-30 16:40 UTC

Description Marc Sauton 2018-03-30 16:40:03 UTC
Description of problem:

web browsers may not be able to access the Dogtag web services pages when the internal SSL server certificate is missing its SAN extension (current default):

we may want to consider this for RHEL-7.5.z if solved upstream:

https://pagure.io/dogtagpki/issue/2979
SAN in internal SSL server certificate in pkispawn configuration step


Version-Release number of selected component (if applicable):
RHEL-7
RHCS-9

How reproducible:
always

Steps to Reproduce:
1. any default install
2.certutil -L -d /etc/pki/subca1/alias/ -n "Server-Cert cert-subca1" | less
3.

Actual results:

by default, we always have 4 extensions:
        Signed Extensions:
            Name: Certificate Authority Key Identifier
            Key ID:
                85:22:b0:87:24:df:df:30:e6:11:46:b6:19:58:00:86:
                82:e3:9b:f3

            Name: Authority Information Access
            Method: PKIX Online Certificate Status Protocol
            Location: 
                URI: "http://ca1.example.com:8444/ca/ocsp"

            Name: Certificate Key Usage
            Critical: True
            Usages: Digital Signature
                    Non-Repudiation
                    Key Encipherment
                    Data Encipherment

            Name: Extended Key Usage
                TLS Web Server Authentication Certificate



Expected results:

need the SAN or CNtoSAN


Additional info:

Comment 2 Matthew Harmsen 2018-04-20 02:05:09 UTC
 Per RHEL 7.5.z/7.6/8.0 Triage:  7.5.z

cfu: I think this one is very much worthwhile to be done in 7.5

Comment 5 Christina Fu 2018-05-19 01:35:12 UTC
Test Procedure:

* Install a CA (with single step pkispawn is good): When complete, check that its SSL server cert bears the Subject Alternative Name (SAN) extension that matches the CN of the cert.

* Install a KRA (on a separate Tomcat instance; (with single step pkispawn is good)): When complete, check that its SSL SSL server cert bears the Subject Alternative Name (SAN) extension that matches the CN of the cert.

* You could test install another subsystem (e.g. subCA) and do the same check.
It should be enough, as far as installation goes.

* Since I changed all *Server* profiles (not limited to the
   *InternalAuthServerCert* ones), you can manually test those too.

* Note that it appears that I have added the changes to the caCMC*server* ones previously.  You could go through CMC enrollment procedure and check them as well.

Comment 6 Christina Fu 2018-05-21 18:11:42 UTC
commit 7eae0d840c1b7494db2cea67744366fe409eafea (HEAD -> DOGTAG_10_5_BRANCH, origin/DOGTAG_10_5_BRANCH, ticket-2995-defaultSANinServerProfiles-r2)
Author: Christina Fu <cfu@redhat.com>
Date:   Thu May 17 19:36:10 2018 -0700

    Ticket #2995 SAN in internal SSL server certificate in pkispawn configuration step
    
    This patch adds CommonNameToSANDefault to all server profiles so that
    SAN will be placed in server certs by default.
    For more flexible SAN or multi-value SAN, SubjectAltNameExtDefault
    will have to be used instead.
    
    fixes: https://pagure.io/dogtagpki/issue/2995
    
    Change-Id: I66556f2cb8ed4e1cbe2d0949c5848c6978ea9641

Comment 9 Sumedh Sidhaye 2018-08-13 12:06:27 UTC
Build used for verification:

root@csqa4-guest01 BZ1471935 # rpm -qi pki-base
Name        : pki-base
Version     : 10.5.9
Release     : 5.el7
Architecture: noarch
Install Date: Sun 12 Aug 2018 04:20:59 AM EDT
Group       : System Environment/Base
Size        : 2122224
License     : GPLv2
Signature   : RSA/SHA256, Thu 09 Aug 2018 08:38:50 PM EDT, Key ID 199e2f91fd431d51
Source RPM  : pki-core-10.5.9-5.el7.src.rpm
Build Date  : Thu 09 Aug 2018 08:25:40 PM EDT
Build Host  : ppc-021.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://pki.fedoraproject.org/
Summary     : Certificate System - PKI Framework


CA certificate:

Subject: CN=csqa4-guest01.idm.lab.eng.rdu.redhat.com,OU=rhcs94-CA-ssidhaye,O=Example-rhcs94-CA

Identifier: Subject Alternative Name - 2.5.29.17
    Critical: no 
    Value: 
        DNSName: csqa4-guest01.idm.lab.eng.rdu.redhat.com

=================================

KRA Certificate:

Subject: CN=csqa4-guest01.idm.lab.eng.rdu.redhat.com,OU=rhcs94-KRA-ssidhaye,O=Example-rhcs94-CA


Identifier: Subject Alternative Name - 2.5.29.17
    Critical: no 
    Value: 
        DNSName: csqa4-guest01.idm.lab.eng.rdu.redhat.com



=========================================



Certificate information using CMC enrollment:

Subject: CN=csqa4-guest01.idm.lab.eng.rdu.redhat.com,OU=pki-tomcat,O=mySecurityDomain

Identifier: Subject Alternative Name - 2.5.29.17
    Critical: no 
    Value: 
        DNSName: csqa4-guest01.idm.lab.eng.rdu.redhat.com


=================================================

Sub CA Certificate:

Subject: CN=csqa4-guest01.idm.lab.eng.rdu.redhat.com,OU=rhcs94-SubCA-ssidhaye,O=Example-rhcs94-SubCA

Identifier: Subject Alternative Name - 2.5.29.17
    Critical: no 
    Value: 
        DNSName: csqa4-guest01.idm.lab.eng.rdu.redhat.com

Comment 11 errata-xmlrpc 2018-10-30 11:05:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3195


Note You need to log in before you can comment on or make changes to this bug.