Bug 1562435 - Octavia dashboard not installed
Summary: Octavia dashboard not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-containers
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Carlos Goncalves
QA Contact: Omri Hochman
Andrew Burden
URL:
Whiteboard:
Depends On:
Blocks: 1433523 1562411
TreeView+ depends on / blocked
 
Reported: 2018-03-30 18:43 UTC by Carlos Goncalves
Modified: 2019-09-10 14:07 UTC (History)
6 users (show)

Fixed In Version: openstack-horizon-container-13.0-13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-28 08:00:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 556888 None master: MERGED kolla: Add octavia-dashboard to horizon image (Ic99e9e7b499e82a998386e13dceab4e67f23e989) 2018-04-03 11:18:21 UTC
OpenStack gerrit 558477 None stable/queens: NEW kolla: Add octavia-dashboard to horizon image (Ic99e9e7b499e82a998386e13dceab4e67f23e989) 2018-04-03 11:18:15 UTC
Red Hat Product Errata RHEA-2018:2085 None None None 2018-06-28 08:01:57 UTC

Description Carlos Goncalves 2018-03-30 18:43:14 UTC
Description of problem:
The Octavia dashboard is not installed in the Horizon docker container on the controller nodes.


How reproducible:
100%

Steps to Reproduce:
1. Deploy the overcloud with Octavia service enabled
2. Login to horizon container
3. Look up for package openstack-octavia-ui

Actual results:
Package openstack-octavia-ui is not installed.


Expected results:
Package openstack-octavia-ui installed.

Additional info:

[root@controller-0 ~]# docker exec -ti horizon bash
()[root@controller-0 /]# rpm -qa | grep octavia
puppet-octavia-12.3.1-0.20180221121608.ebe409c.el7ost.noarch
()[root@controller-0 /]# rpm -qa | grep openstack-.*-ui
openstack-neutron-lbaas-ui-4.0.1-0.20180228134224.a42434a.el7ost.noarch
openstack-sahara-ui-8.0.1-0.20180301091310.707059f.el7ost.noarch
openstack-manila-ui-2.13.1-0.20180220035500.51ce208.el7ost.noarch
openstack-ironic-ui-3.1.1-0.20180223163216.1c4cbd2.el7ost.noarch

Comment 3 Jon Schlueter 2018-04-03 11:17:45 UTC
There is also a tripleo component to enable this as well that is needed.

Comment 4 Carlos Goncalves 2018-04-03 11:23:27 UTC
It is being tracked in rhbz#1562411

Comment 10 errata-xmlrpc 2018-06-28 08:00:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2085


Note You need to log in before you can comment on or make changes to this bug.