Bug 1562477 - FFU: updating stack outputs fails on environments with management network enabled: Could not fetch contents for file:///tmp/tripleoclient-kjhsMm/tripleo-heat-templates/network/ports/management.yaml
Summary: FFU: updating stack outputs fails on environments with management network ena...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jiri Stransky
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-31 02:11 UTC by Marius Cornea
Modified: 2018-06-27 13:50 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:49:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1765547 None None None 2018-04-19 23:06:16 UTC
OpenStack gerrit 563637 None stable/queens: MERGED tripleo-heat-templates: Enable management network in network_data (I39b1a70f0a27bdab4d6280d54107ff209d4bb67d) 2018-04-24 16:06:05 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:50:27 UTC

Description Marius Cornea 2018-03-31 02:11:20 UTC
Description of problem:
FFU: updating stack outputs fails on environments with management network enabled: Could not fetch contents for file:///tmp/tripleoclient-kjhsMm/tripleo-heat-templates/network/ports/management.yaml

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with management network enabled:

openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-management.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e ~/openstack_deployment/environments/enable-cpu-pinning.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/scheduler_hints_env.yaml \
-e ~/openstack_deployment/environments/ips-from-pool-all.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
-e ~/openstack_deployment/environments/custom_hiera.yaml \

2. Upgrade undercloud to OSP11/12/13

3. Run the FFU step to update stack output:

openstack overcloud deploy --templates /usr/share/openstack-tripleo-heat-templates \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-management.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e ~/openstack_deployment/environments/enable-cpu-pinning.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/scheduler_hints_env.yaml \
-e ~/openstack_deployment/environments/ips-from-pool-all.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml \
-e ~/openstack_deployment/environments/custom_hiera.yaml \
-e /home/stack/virt/docker-images.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/fast-forward-upgrade.yaml \
-e /home/stack/ffu_repos.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/config-download-environment.yaml \
-e /home/stack/ceph-ansible-env.yaml \


Actual results:

Fails with with:

Could not fetch contents for file:///tmp/tripleoclient-kjhsMm/tripleo-heat-templates/network/ports/management.yaml

Expected results:
Updating stack output step completes fine.

Additional info:

Comment 2 Marios Andreou 2018-04-02 12:59:10 UTC
o/ jistr please triage this we are going through the list and assigning round robin thanks (DFG:Upgrades triage call)

Comment 3 Jiri Stransky 2018-04-03 09:24:02 UTC
+1 as a FFU blocker. It's possible that the management port file didn't get rendered because the management network is not enabled by default in Queens.

Comment 5 Lukas Bezdicka 2018-04-11 15:10:04 UTC
We should reenable the management network, this was not backwards compatible change.

Comment 6 Jiri Stransky 2018-04-23 16:06:14 UTC
Fix by Marius, backport proposed to stable/queens.

Comment 11 Scott Lewis 2018-04-30 14:59:49 UTC
This item has been properly Triaged and planned for the OSP13 release, and is being tagged for tracking. For details, see https://url.corp.redhat.com/1851efd

Comment 13 errata-xmlrpc 2018-06-27 13:49:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.