Bug 1562538 - Graphics Corruption When Using AMD GPU
Summary: Graphics Corruption When Using AMD GPU
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: 0ad
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paulo Andrade
QA Contact: Fedora Extras Quality Assurance
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-31 19:35 UTC by ali.sherif10
Modified: 2018-10-30 07:12 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 07:12:14 UTC
Type: Bug


Attachments (Terms of Use)
Players' menu is corrupted. (976.34 KB, image/png)
2018-03-31 19:35 UTC, ali.sherif10
no flags Details
Players' menu is corrupted. (952.00 KB, image/png)
2018-03-31 19:37 UTC, ali.sherif10
no flags Details
Technology tree is corrupted. (1.08 MB, image/png)
2018-03-31 19:38 UTC, ali.sherif10
no flags Details

Description ali.sherif10 2018-03-31 19:35:58 UTC
Created attachment 1415634 [details]
Players' menu is corrupted.

Description of problem:
Graphics at players' menu and technology tree are corrupted, when the AMD GPU is used.
When the Intel GPU is used, graphics are fine.

Version-Release number of selected component (if applicable):
Latest version available from FlatHub on the date of the creation of this report.
Also, the version from Fedora from the days of Fedora 26 is affected. I expect the current version from Fedora is also affected.

How reproducible:
Always.

Steps to Reproduce:
1. Install 0 AD from FlatHub.
2. Click the start button.
3. Right click on the application icon.
4. Click "Launch using Dedicated Graphics Card".

Actual results:
Graphics are corrupted as shown in the attached screenshots.

Expected results:
Graphics appear properly.

Additional info:
xorg-x11-drv-ati is installed.
Output of $ lspci | grep VGA:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (rev ff)

Comment 1 ali.sherif10 2018-03-31 19:37:11 UTC
Created attachment 1415635 [details]
Players' menu is corrupted.

Comment 2 ali.sherif10 2018-03-31 19:38:21 UTC
Created attachment 1415636 [details]
Technology tree is corrupted.

Comment 3 ali.sherif10 2018-03-31 22:36:04 UTC
I made a report on Freedesktop bugs.

Comment 4 ali.sherif10 2018-10-30 07:12:14 UTC
The bug seems to be fixed in Fedora 28 in the Flatpak version.
Should someone change it to fixed?


Note You need to log in before you can comment on or make changes to this bug.