Bug 156278 - ainit uses char for getc() result, fills .asoundrc with 0xff until killed.
ainit uses char for getc() result, fills .asoundrc with 0xff until killed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 12:17 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.0.9rc2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 12:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2005-04-28 12:17:44 EDT
The getc() function returns a 'int', not a 'char'. Compiling ainit on a machine
where 'char' is unsigned results in these warnings:

ainit.c: In function 'read_token':
ainit.c:194: warning: comparison is always true due to limited range of data type
ainit.c: In function 'parse_file':
ainit.c:223: warning: comparison is always true due to limited range of data type

... because a char cannot hold the value '-1'.

Note You need to log in before you can comment on or make changes to this bug.