Bug 156288 - (PERLMULTILIB) perl.i386 must be removed from FC3
perl.i386 must be removed from FC3
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
: 156379 156444 156473 156565 157169 157337 159893 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-28 13:01 EDT by Panu Matilainen
Modified: 2014-03-16 22:53 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 22:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2005-04-28 13:01:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
i386 version of perl is missing from x86_64 updates repository causing updates to fail with conflicts:

[root@weasel ~]# yum update
...
Finished Transaction Test
Transaction Check Error:   file /usr/share/man/man1/c2ph.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/find2perl.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/h2ph.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/h2xs.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
  file /usr/share/man/man1/libnetcfg.1.gz from install of perl-5.8.5-11.FC3 conflicts with file from package perl-5.8.5-9
...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to apply updates to FC3 x86_64 system which has perl installed
  

Actual Results:  See description...

Additional info:

Easily fixed by copying the i386-version of this update to x86_64 repository as well. Or worked around by just removing the i386-version of perl, I kinda wonder why is it included in the first place since nothing seems to need it?
Comment 1 Bill Nottingham 2005-04-28 22:33:14 EDT
perl is not a multilib package. It was originally pushed there erroneously.
Please remove the i386 version before upgrading.
Comment 2 Warren Togami 2005-04-28 23:03:31 EDT
(This means x86_64 users should use 'yum remove perl.i386'.  We have no other
way out of this unfortunately.)
Comment 3 Warren Togami 2005-04-29 13:30:28 EDT
*** Bug 156379 has been marked as a duplicate of this bug. ***
Comment 4 Warren Togami 2005-04-30 16:22:59 EDT
*** Bug 156444 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2005-04-30 20:10:49 EDT
*** Bug 156473 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2005-05-01 16:38:11 EDT
*** Bug 156565 has been marked as a duplicate of this bug. ***
Comment 7 Jonathan S. Shapiro 2005-05-01 21:26:25 EDT
Warren:

"We have no other way out of this..."

Why not reissue perl.x86_64 as 5.8.5-12 and mark it as obsoleting the earlier
i386 version?

If there is some reason that this is infeasible, this needs a notice somewhere
so that people can figure out what's up.
Comment 8 Jonathan S. Shapiro 2005-05-01 21:29:13 EDT
And while I'm thinking about it. This should not be "closed notabug". It bloody
well is a bug. It should be marked as "closed wontfix" or "closed deferred".
Don't corrupt the bug database with bad data!
Comment 9 Warren Togami 2005-05-01 23:38:17 EDT
It is impossible to Require/Obsolete/Conflict a different arch.
Comment 10 Phil Anderson 2005-05-01 23:43:28 EDT
Does anyone know what the effect of this will be if you try to upgrade a FC3 box
to FC4?  Will it cause the upgrade to fail?  If so, should there be a nasty hack
in anaconda which removes perl.i386?  Or would an item in the release notes be
enough?
Comment 11 Warren Togami 2005-05-01 23:45:53 EDT
I tested that today.  The results are disasterous.  I'm trying to get a nasty
hack added to anaconda because you cannot rely on humans to read documentation.
Comment 12 Jonathan S. Shapiro 2005-05-02 14:12:12 EDT
If I understand Warren's comment, it is not possible today for an RPM on one
architecture to obsolete an RPM from another architecture.

In principle, I don't see any reason why an Obsoletes: line should not be able
to specify obsoletes behavior across architectures.

Given that several targets are now multiarchitecture at user level (notably
x86_64, ia64), should this be filed as a recommended enhancement for RPM?
Comment 13 Warren Togami 2005-05-07 23:38:54 EDT
*** Bug 157169 has been marked as a duplicate of this bug. ***
Comment 14 Brian Daniels 2005-05-07 23:59:41 EDT
You also might want to investigate why Bugzilla searches on either
perl-5.8.5-11.FC3 or perl-5.8.5-9 both find nothing, even when searching
descriptions.  That is why you are getting so many duplicates.  It's quite
annoying to do multiple searches before going to the trouble of writing up a
bug, only to find it's a dupe anyway.
Comment 15 Warren Togami 2005-05-10 14:42:22 EDT
*** Bug 157337 has been marked as a duplicate of this bug. ***
Comment 16 Warren Togami 2005-06-08 18:57:00 EDT
*** Bug 159893 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.