Bug 15629 - kernel-headers have version 2.4.0-0.16 and kernel-source install problem (BAD)
kernel-headers have version 2.4.0-0.16 and kernel-source install problem (BAD)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 07:45 EDT by o.schnapauff
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 20:16:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description o.schnapauff 2000-08-07 07:45:11 EDT
Pinstripe installs kernel-headers-2.4.0-0.16.i386.rpm  
kernel-source-2.2.16-17.i386.rpm
kernel-2.2.16-17.i686.rpm

Why do we carry 2.4.0 header? When compiling kernel modules on such a
system the modules arent usable because they use wrong headers and version
information.

Also (maybe rpm bug)
[root@rhbeta RPMS]# rpm -i kernel-source-2.2.16-17.i386.rpm 
var/tmp/rpm-tmp.65670: line 14: syntax error: unexpected end of file
execution of kernel-source-2.2.16-17 script failed, exit status 2

Bug we got

[root@rhbeta RPMS]# df -a
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda7              1344016    774200    501544  61% /
none                         0         0         0   -  /proc
usbdevfs                     0         0         0   -  /proc/bus/usb
none                         0         0         0   -  /dev/pts
/dev/hdc                666250    666250         0 100% /mnt/cdrom


[root@rhbeta RPMS]# ls -l kernel-source-2.2.16-17.i386.rpm 
-rw-r--r--    3 root     root     17832250 Jul 27 01:01
kernel-source-2.2.16-17.i386.rpm

But the worst thing is BADBAD: 

[root@rhbeta RPMS]# rpm -i kernel-source-2.2.16-17.i386.rpm 
package kernel-source-2.2.16-17 is already installed

After a failed install is should _not_ be installed.


Also:In file included from /usr/src/linux/include/linux/module.h:203,
                 from toshiba.c:44:
/usr/src/linux/include/linux/version.h:13:26: /boot/kernel.h: Datei oder
Verzeichnis nicht gefunden

[olaf@rhbeta src]$ ls /boot/
boot.0300              message                System.map-2.2.16-17
boot.b                 module-info            vmlinux-2.2.16-17
chain.b                module-info-2.2.16-17  vmlinuz
kernel.h-2.2.16        os2_d.b                vmlinuz-2.2.16-17
map                    System.map             

we need a kernel.h not a kernel.h-2.2.16
Comment 1 Alan Cox 2000-08-07 20:16:50 EDT
The 2.4 headers are for glibc and link to /usr/include/linux which is correct

This is fixed:
  Also (maybe rpm bug)
  [root@rhbeta RPMS]# rpm -i kernel-source-2.2.16-17.i386.rpm 
   var/tmp/rpm-tmp.65670: line 14: syntax error: unexpected end of file
   execution of kernel-source-2.2.16-17 script failed, exit status 2

The other one may be a bug yes..


Comment 2 Michael K. Johnson 2000-08-08 23:16:05 EDT
I believe the header file problem is fixed in our
current source tree.

post script failures have never caused rpm to roll back
installs.

That failure will show up once more when you upgrade to
a more recent kernel, then disappear, it's just a typo
caused by changing syntax from rpm to shell.

So, as far as I can tell, everything here (with the
exception of one thing that isn't a bug) is fixed in
our current source tree.

Note You need to log in before you can comment on or make changes to this bug.