Bug 1562943 - CRI-O requires nodes labelled as "runtime=cri-o"
CRI-O requires nodes labelled as "runtime=cri-o"
Status: CLOSED DUPLICATE of bug 1553452
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.9.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-02 13:44 EDT by Wolfgang Kulhanek
Modified: 2018-04-02 22:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-02 22:01:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Kulhanek 2018-04-02 13:44:59 EDT
Description of problem:

Version-Release number of the following components:
OCP 3.9 GA

How reproducible:

Steps to Reproduce:
1. Try to install OCP with CRI-O support and Garbage Collection Support enabled
2. Install fails with a message that no nodes labelled "runtime=cri-o" are found


This is either an installer or a docs bug. Relevant Docs:
  https://docs.openshift.com/container-platform/3.9/release_notes/ocp_3_9_release_notes.html#ocp-39-crio

openshift_use_crio=true
openshift_crio_enable_docker_gc=true

Docs say on "openshift_crio_enable_docker_gc":
When enabled, it will run garbage collection on all nodes by default. You can also limit the running of the daemonset on specific nodes by setting the following:

  openshift_crio_docker_gc_node_selector={'runtime': 'cri-o'}

However this setting seems to be the default and if no nodes in the cluster are labelled as "runtime=cri-o" the install fails.
Comment 1 Johnny Liu 2018-04-02 22:01:38 EDT
We already have a installer bug to track this:
https://bugzilla.redhat.com/show_bug.cgi?id=1553452

For doc, there is some statement about it:
"""
For example, the above would ensure it is only run on nodes with the runtime: cri-o label. 
"""

From QE's view, the statement is already clear.

Here I will close this bug as a DUP. If you still think the doc is not clear enough, pls reopen it, and move it to "Document" component. Thx.

*** This bug has been marked as a duplicate of bug 1553452 ***

Note You need to log in before you can comment on or make changes to this bug.