Bug 1563002 - Monitor Event Queue PG::Error
Summary: Monitor Event Queue PG::Error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscription Management
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Partha Aji
QA Contact: Ranjan Kumar
URL:
Whiteboard:
: 1510665 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-02 21:46 UTC by Jason Dickerson
Modified: 2019-06-13 21:26 UTC (History)
8 users (show)

Fixed In Version: tfm-rubygem-katello-3.4.5.69-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1572303 (view as bug list)
Environment:
Last Closed: 2018-06-19 20:17:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 23096 Normal Closed Indexing subscription facet pools generates sql query per consumer 2020-07-23 11:43:46 UTC
Red Hat Product Errata RHBA-2018:1950 None None None 2018-06-19 20:17:33 UTC

Description Jason Dickerson 2018-04-02 21:46:20 UTC
Description of problem:
Katello Monitor Event Queue encounters the following postgresql error:

PG::Error: ERROR:  insert or update on table \"katello_subscription_facet_pools\" violates foreign key constraint \"katello_sub_facet_pools_sf_id_fk\"\nDETAIL:  Key (subscription_facet_id)=(283617) is not present in table \"katello_subscription_facets\".\n: INSERT INTO \"katello_subscription_facet_pools\" (\"pool_id\", \"subscription_facet_id\") VALUES ($1, $2) RETURNING \"id\"

Version-Release number of selected component (if applicable):


How reproducible:

Monitor Event Queue encounters this often, and normally continues running, but sometimes crashes.  The crash may or may not be related to this error.  

Steps to Reproduce:
1. Watch the output of the Monitor Event Queue
2.
3.

Actual results:
See the error

Expected results:
no errors

Additional info:

Comment 1 Partha Aji 2018-04-02 22:55:15 UTC
Connecting redmine issue http://projects.theforeman.org/issues/23096 from this bug

Comment 3 pm-sat@redhat.com 2018-04-04 04:28:38 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/23096 has been resolved.

Comment 10 errata-xmlrpc 2018-06-19 20:17:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1950

Comment 11 Brad Buckingham 2018-06-25 18:49:04 UTC
*** Bug 1510665 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.