Bug 1563121 - No exception's handling on SerialChildCommandsExecutionCallback
Summary: No exception's handling on SerialChildCommandsExecutionCallback
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.2.3
: 4.2.3.2
Assignee: shani
QA Contact: Evelina Shames
URL:
Whiteboard:
Depends On:
Blocks: 1568878
TreeView+ depends on / blocked
 
Reported: 2018-04-03 07:52 UTC by shani
Modified: 2018-05-10 06:28 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.2.3.2
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1568878 (view as bug list)
Environment:
Last Closed: 2018-05-10 06:28:19 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 89726 0 master MERGED core: SerialChildCommandsExecutionCallback exception handling 2020-10-19 06:00:10 UTC
oVirt gerrit 89770 0 ovirt-engine-4.1 MERGED core: SerialChildCommandsExecutionCallback exception handling 2020-10-19 06:00:22 UTC
oVirt gerrit 89771 0 ovirt-engine-4.2 MERGED core: SerialChildCommandsExecutionCallback exception handling 2020-10-19 06:00:10 UTC

Description shani 2018-04-03 07:52:43 UTC
Description of problem:
In case of getting an exception at childCommandsExecutionEnded#serialChildExecutingCommand.performNextOperation(completedChildren), it's not logged on the engine.log.
In addition, current code has 3 placeholders for 4 arguments, so the last one is being ignored.

Version-Release number of selected component (if applicable):
master - 0c907f230e

How reproducible:
100%

Steps to Reproduce:
1. Throw an exception at serialChildExecutingCommand.performNextOperation(completedChildren)

Actual results:
2018-04-03 10:51:39,037+03 INFO  [org.ovirt.engine.core.bll.SerialChildCommandsExecutionCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-60) [48e6c155-fadb-4577-8cf1-c9876e447dd9] Command 'CreateSnapshotForVm' id: '5704fd4c-f0b5-4950-a38a-535392ad22d3' failed when attempting to perform the next operation, marking as FAILED '[06ad2307-0b46-487a-beea-25a527474a02]'
2018-04-03 10:51:49,625+03 INFO  [org.ovirt.engine.core.bll.SerialChildCommandsExecutionCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-60) [48e6c155-fadb-4577-8cf1-c9876e447dd9] Command 'CreateSnapshotForVm' id: '5704fd4c-f0b5-4950-a38a-535392ad22d3' child commands '[06ad2307-0b46-487a-beea-25a527474a02]' executions were completed, status 'FAILED'

Expected results:
The error should be logged properly:

2018-04-02 18:29:48,483+03 ERROR [org.ovirt.engine.core.bll.SerialChildCommandsExecutionCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-15) [54572893-8e69-440d-92c4-b4872ad90d57] Command 'CreateSnapshotForVm' id: '04317ab9-8d26-4b02-82ba-8b4213c008a7' children [ab274fe6-922e-40b6-8eed-e9946206ddf1] failed when attempting to perform the next operation, marking as FAILED 'FAILED'
2018-04-02 18:29:48,484+03 ERROR [org.ovirt.engine.core.bll.SerialChildCommandsExecutionCallback] (EE-ManagedThreadFactory-engineScheduled-Thread-15) [54572893-8e69-440d-92c4-b4872ad90d57] MyException: java.lang.Exception: MyExcepetion!
	at org.ovirt.engine.core.bll.SerialChildCommandsExecutionCallback.childCommandsExecutionEnded(SerialChildCommandsExecutionCallback.java:36) [bll.jar:]
...

Additional info:
-

Comment 1 Allon Mureinik 2018-04-03 09:02:52 UTC
While this bug has very little functional impact (the command fails regardless), the current log lacks a lot of information and makes debugging issues quite difficult.

Moreover, the proposed fix seems quite minimal and safe.

Proposing to backport this fix all the way down to 4.1.11, to help debugging issues in the field easier.

Comment 4 Sandro Bonazzola 2018-05-10 06:28:19 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.