Bug 1563177 - calligra-sheets package doesn't depend on calligra-sheets-libs
Summary: calligra-sheets package doesn't depend on calligra-sheets-libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calligra
Version: 27
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-03 11:00 UTC by Benjamin Xiao
Modified: 2018-04-15 14:44 UTC (History)
1 user (show)

Fixed In Version: calligra-3.1.0-6.fc28 calligra-3.1.0-6.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-15 02:34:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Benjamin Xiao 2018-04-03 11:00:23 UTC
Description of problem:
Latest calligra-sheets package doesn't depend on calligra-sheets-libs, even though Calligra Sheets can not even properly launch without calligra-sheets-libs being installed.

Version-Release number of selected component (if applicable): 3.1.0-2


How reproducible:
Every time


Steps to Reproduce:
1. On updated system, run `sudo dnf autoremove`. calligra-sheets-libs will be autoremoved.
2. If calligra-sheets-libs is somehow marked as user installed, do `sudo dnf mark remove calligra-sheets-libs`, then do the autoremove.
2. Try to run Calligra Sheets. It will fail.

Actual results:
calligra-sheets doesn't hard depend on calligra-sheets-libs, even though it is necessary for the proper functioning of calligra-sheets


Expected results:
1. calligra-sheets-libs should not be autoremoved due to calligra-sheets dependency on it.
2. Forcibly removing calligra-sheets-libs should cause calligra-sheets main package to be removed as well.


Additional info:

Comment 1 Rex Dieter 2018-04-06 14:49:44 UTC
Thanks for your report,

%changelog
* Fri Apr 06 2018 Rex Dieter <rdieter@fedoraproject.org> - 3.1.0-6
- calligra-sheets package doesn't depend on calligra-sheets-libs (#1563177)
- use %%make_build %%ldconfig_scriptlets

Comment 2 Fedora Update System 2018-04-06 20:49:01 UTC
calligra-3.1.0-6.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7ba1eaeb12

Comment 3 Fedora Update System 2018-04-06 20:52:34 UTC
calligra-3.1.0-6.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0239c36c12

Comment 4 Fedora Update System 2018-04-07 23:37:40 UTC
calligra-3.1.0-6.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0239c36c12

Comment 5 Fedora Update System 2018-04-08 00:03:48 UTC
calligra-3.1.0-6.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7ba1eaeb12

Comment 6 Fedora Update System 2018-04-15 02:34:49 UTC
calligra-3.1.0-6.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2018-04-15 14:44:53 UTC
calligra-3.1.0-6.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.