RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1563423 - SELinux prevents Postfix/cleanup from accessing OpenDKIM UNIX socket
Summary: SELinux prevents Postfix/cleanup from accessing OpenDKIM UNIX socket
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.4
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-03 22:38 UTC by are-support
Modified: 2018-10-30 10:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:03:16 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 0 None None None 2018-10-30 10:04:01 UTC

Description are-support 2018-04-03 22:38:42 UTC
Description of problem:
SELinux prevents Postfix from accessing the OpenDKIM UNIX socket when it is specified under non_smtpd_milters.

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-166.el7_4.9
postfix-2:2.10.1-6.el7
opendkim-2.11.0-0.1.el7

How reproducible:
Always, when OpenDKIM is configured to use a local UNIX socket and Postfix is configured to use it with non_smtpd_milters.

Steps to Reproduce:
1. Configure OpenDKIM to use a socket at /var/run/opendkim/opendkim.sock
2. Add the socket to Postfix using non_smtpd_milters = unix:/var/run/opendkim/opendkim.sock
3. Restart Postfix and try to send mail

Actual results:
OpenDKIM milter rejects mail with "postfix/cleanup[1612]: warning: connect to Milter service unix:/var/run/opendkim/opendkim.sock: Permission denied"

Expected results:
OpenDKIM milter should accept and process mail

Additional info:
Entries in audit.log confirm that SELinux is preventing access to the socket. Identical bug is shown here as fixed in Fedora: https://bugzilla.redhat.com/show_bug.cgi?id=1436026. Using audit2allow to generate a custom policy addition solves the error.

Comment 2 Milos Malik 2018-06-13 13:48:49 UTC
Please collect SELinux denials and attach them here:

# ausearch -m avc -m user_avc -m selinux_err -m user_selinux_err -i -ts today

Comment 3 Milos Malik 2018-06-13 13:49:52 UTC
I'm sorry, they are already present in BZ#1436026.

Comment 4 are-support 2018-06-13 15:40:06 UTC
Here it is just in case:

type=AVC msg=audit(03/28/2018 11:22:33.110:2352) : avc:  denied  { connectto } for  pid=32428 comm=cleanup path=/run/opendkim/opendkim.sock scontext=system_u:system_r:postfix_cleanup_t:s0 tcontext=system_u:system_r:dkim_milter_t:s0 tclass=unix_stream_socket

Comment 8 errata-xmlrpc 2018-10-30 10:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.