Bug 1563448 - [abrt] system-config-language: decode(): ascii.py:26:decode:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 1513: ordinal not in range(128)
Summary: [abrt] system-config-language: decode(): ascii.py:26:decode:UnicodeDecodeErro...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-language
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Parag Nemade
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:36bc3ca93e3002431435d305e52...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 01:31 UTC by mastaiza
Modified: 2018-09-10 17:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-25 15:23:34 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (9.11 KB, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details
File: cgroup (341 bytes, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details
File: cpuinfo (1.12 KB, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details
File: environ (189 bytes, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details
File: mountinfo (3.64 KB, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details
File: namespaces (129 bytes, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details
File: open_fds (942 bytes, text/plain)
2018-04-04 01:31 UTC, mastaiza
no flags Details

Description mastaiza 2018-04-04 01:31:42 UTC
Version-Release number of selected component:
system-config-language-3.4.2-6.fc28

Additional info:
reporter:       libreport-2.9.4
cmdline:        /usr/bin/python3 /usr/share/system-config-language/system-config-language.py
crash_function: decode
exception_type: UnicodeDecodeError
executable:     /usr/share/system-config-language/system-config-language.py
interpreter:    python3-3.6.4-20.fc28.x86_64
kernel:         4.16.0-0.rc7.git0.1.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
#1 decode in /usr/lib64/python3.6/encodings/ascii.py:26
#2 read_table in /usr/share/system-config-language/language_backend.py:94
#3 fill_store in /usr/share/system-config-language/language_gui.py:125
#4 __init__ in /usr/share/system-config-language/language_gui.py:60
#5 do_activate in /usr/share/system-config-language/language_gui.py:348

Potential duplicate: bug 1334022

Comment 1 mastaiza 2018-04-04 01:31:48 UTC
Created attachment 1416995 [details]
File: backtrace

Comment 2 mastaiza 2018-04-04 01:31:50 UTC
Created attachment 1416996 [details]
File: cgroup

Comment 3 mastaiza 2018-04-04 01:31:52 UTC
Created attachment 1416997 [details]
File: cpuinfo

Comment 4 mastaiza 2018-04-04 01:31:53 UTC
Created attachment 1416998 [details]
File: environ

Comment 5 mastaiza 2018-04-04 01:31:55 UTC
Created attachment 1416999 [details]
File: mountinfo

Comment 6 mastaiza 2018-04-04 01:31:57 UTC
Created attachment 1417000 [details]
File: namespaces

Comment 7 mastaiza 2018-04-04 01:31:59 UTC
Created attachment 1417001 [details]
File: open_fds

Comment 8 Parag Nemade 2018-04-06 11:45:18 UTC
Provide information like
1) Which Desktop environment are you using? GNOME or KDE or anyother.
2) What language you tried to set/install?

Comment 9 mastaiza 2018-04-16 19:30:05 UTC
1) LXDE
2) wanted to put Russian language

Comment 10 Parag Nemade 2018-07-24 03:36:33 UTC
sorry for late reply but do you still see this issue exists in Fedora 28?

Comment 11 mastaiza 2018-07-25 14:44:04 UTC
Hello the problem is no longer observed

Comment 12 Parag Nemade 2018-07-25 15:23:34 UTC
Thank you for your reply. I will close this now. Report new bugzilla if you will find any other issues.

Comment 13 mastaiza 2018-07-25 16:45:08 UTC
ok

Comment 14 Daniel 2018-09-10 17:33:14 UTC
Similar problem has been detected:

thunderbird crashed at start 

reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 /usr/share/system-config-language/system-config-language.py
crash_function: decode
exception_type: UnicodeDecodeError
executable:     /usr/share/system-config-language/system-config-language.py
interpreter:    python3-3.6.6-1.fc28.x86_64
kernel:         4.17.19-200.fc28.x86_64
package:        system-config-language-3.4.2-6.fc28
reason:         ascii.py:26:decode:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 1513: ordinal not in range(128)
runlevel:       N 5
type:           Python3
uid:            0


Note You need to log in before you can comment on or make changes to this bug.