Bug 1563540 - [Ansible Tower] - unexpected token - credentials validation
Summary: [Ansible Tower] - unexpected token - credentials validation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Alexander Zagaynov
QA Contact: Nandini Chandra
URL:
Whiteboard: tower
Depends On:
Blocks: 1614417
TreeView+ depends on / blocked
 
Reported: 2018-04-04 06:55 UTC by Pavol Kotvan
Modified: 2019-08-22 00:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1614417 (view as bug list)
Environment:
Last Closed: 2019-06-11 15:26:44 UTC
Category: Bug
Cloudforms Team: Ansible
Target Upstream Version:


Attachments (Terms of Use)
3.2.2 different message (32.08 KB, image/png)
2018-07-12 09:35 UTC, Tomas Coufal
no flags Details

Comment 4 bascar 2018-04-10 12:47:14 UTC
Please add to both the documentation and on screen in the provider configuration screen just above the credentials so it is obvious.

Comment 5 Tomas Coufal 2018-07-12 09:35:32 UTC
Created attachment 1458325 [details]
3.2.2 different message

Comment 6 Tomas Coufal 2018-07-12 09:42:40 UTC
I'm getting much cleaner message when using Tower 3.2.2 (see attachment 1458325 [details]).

However I'm not sure, if we should be assuming why the credential validation failed. It should be the Tower telling us the cause. If Tower API doesn't state that clearly, why should CFME be the one guessing what the problem is? What do you think, Brad?

I agree that it would make sense to have the "ENABLE HTTP BASIC AUTH in Tower has to be ON" in our documentation, though.

Comment 7 bascar 2018-07-17 14:40:02 UTC
We should show the message as the user trying to add this is an advanced admin type user. Just show the message without interpretation. If this in fact the message being sent by Tower and it is incorrect then we should place a BZ on Tower. 

Even with all of that, this is something that needs to go on the documentation and even explained on the screen above the validate button like: 

Please note that in Tower you must set a configuration setting: "Enable HTTP BASIC Auth" as described in the product documentation.

Comment 8 Tomas Coufal 2018-08-09 14:28:58 UTC
Ok. Will do. I'll place the note on the provider config screen and clone this BZ against documentation team. ;)


Note You need to log in before you can comment on or make changes to this bug.