Bug 1563541 - Install etcd failed when deploy OCP on Atomic Host
Summary: Install etcd failed when deploy OCP on Atomic Host
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Vadim Rutkovsky
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 06:56 UTC by Weihua Meng
Modified: 2018-07-30 19:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:11:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:12:03 UTC

Description Weihua Meng 2018-04-04 06:56:35 UTC
Description of problem:
Install etcd failed when deploy OCP on Atomic Host

Install successfully on RHEL

Version-Release number of the following components:
openshift-ansible-3.10.0-0.15.0.git.0.556ddbb.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. deploy OCP 3.10 on Atomic Host
$ ansible-playbook  playbooks/deploy_cluster.yml


Actual results:
TASK [etcd : Install etcd] *****************************************************
Tuesday 03 April 2018  22:34:42 -0400 (0:00:00.024)       0:02:18.355 ********* 
FAILED - RETRYING: Install etcd (2 retries left).
FAILED - RETRYING: Install etcd (1 retries left).
fatal: [qe-wmengah310et-master-etcd-1.0403-qn5.qe.rhcloud.com]: FAILED! => {"attempts": 2, "changed": false, "failed": true, "msg": "Could not find a module for unknown."}

NO MORE HOSTS LEFT *************************************************************

Expected results:
Install successfully

Comment 1 Weihua Meng 2018-04-04 07:40:37 UTC
Test on Atomic Host is blocked by this bug.

Comment 3 Scott Dodson 2018-04-05 13:57:46 UTC
Believed to be fixed in https://github.com/openshift/openshift-ansible/pull/7770

Comment 4 Weihua Meng 2018-04-07 02:30:25 UTC
Fixed.
openshift-ansible-3.10.0-0.16.0.git.0.8925606.el7.noarch.rpm

TASK [etcd : Install etcd] *****************************************************
Friday 06 April 2018  20:50:21 -0400 (0:00:00.055)       0:08:04.838 ********** 
skipping: [qe-wmengah310162-master-etcd-1.0406-83q.qe.rhcloud.com] => {"changed": false, "skip_reason": "Conditional result was False", "skipped": true}

Comment 6 errata-xmlrpc 2018-07-30 19:11:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.