Bug 1563548 - Unable to unset static routes from a router with python-openstackclient version 3.2.1-2
Summary: Unable to unset static routes from a router with python-openstackclient versi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: z9
: 10.0 (Newton)
Assignee: Bernard Cafarelli
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 07:22 UTC by Punit Kundal
Modified: 2018-09-17 17:00 UTC (History)
7 users (show)

Fixed In Version: python-openstackclient-3.2.1-5.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, the command to unset static routes from a router failed with the error 'Router does not contain route xxx'. With this fix, the command 'openstack router unset --route' is now successful.
Clone Of:
Environment:
Last Closed: 2018-09-17 16:59:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1631471 None None None 2018-06-12 15:28:31 UTC
Red Hat Product Errata RHBA-2018:2671 None None None 2018-09-17 17:00:47 UTC

Comment 2 Bernard Cafarelli 2018-06-12 15:28:31 UTC
Calling "openstack router unset --route destination=192.168.100.0/24,gateway=192.168.100.2 ro1" fails with error:
Router does not contain route {u'destination': u'192.168.100.0/24', u'gateway': u'192.168.100.2'}

I could reproduce it with python-openstackclient-3.2.1-1 to -4

This looks similar to https://bugs.launchpad.net/python-openstackclient/+bug/1631471

Comment 10 Alex McLeod 2018-09-03 07:57:12 UTC
Hi there,

If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field.

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Thanks,
Alex

Comment 12 errata-xmlrpc 2018-09-17 16:59:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2671


Note You need to log in before you can comment on or make changes to this bug.