Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1563549 - Global flags --v/--loglevel duplicate display in sub commands help info
Summary: Global flags --v/--loglevel duplicate display in sub commands help info
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Juan Vallejo
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 07:23 UTC by Xingxing Xia
Modified: 2018-04-24 03:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 10:30:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Xingxing Xia 2018-04-04 07:23:16 UTC
Description of problem:
Flags --v/--loglevel duplicate

Version-Release number of selected component (if applicable):
v3.10.0-0.15.0

How reproducible:


Steps to Reproduce:
Flags --v/--loglevel duplicate:
1. `oc [adm] options`
2. `oc adm diagnostics -h` and all `diagnostics` sub commands

Actual results:
1. --v and --loglevel displayed in separate lines
2. --v/--loglevel are global options, but displayed in help info of sub commands

Expected results:
1. Remove one of --v and --loglevel, or display them in same line
2. Global options are not duplicate displayed in sub commands help info

Additional info:

Comment 1 Juan Vallejo 2018-04-04 14:04:17 UTC
Maciej, was it intended behavior to display --v in subcommands?

Comment 2 Maciej Szulik 2018-04-04 14:19:17 UTC
Yes, this is intentional. We'll be slowly replacing --loglevel with --v to be compliant with kubernetes which uses the latter.

Comment 3 Xingxing Xia 2018-04-08 01:13:32 UTC
(In reply to Xingxing Xia from comment #0)
> Actual results:
> 2. --v/--loglevel are global options, but displayed in help info of sub
> commands

> Expected results:
> 2. Global options are not duplicate displayed in sub commands help info
Thanks for clarification. But the duplication in point 2 should be fixed.

Comment 4 Maciej Szulik 2018-04-10 10:30:55 UTC
We will not remove any of the two entries until one of them (loglevel) will be deprecated.

Comment 5 Xingxing Xia 2018-04-24 03:34:37 UTC
Hmm, fyi, the point 2 issue is in fact fixed in oc v3.10.0-0.27.0, subcommands does not dipslay global --v/--loglevel now in help info. Thanks


Note You need to log in before you can comment on or make changes to this bug.