Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1563559 - No "allowVolumeExpansion" field in "oc describe sc"
Summary: No "allowVolumeExpansion" field in "oc describe sc"
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Bradley Childs
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 07:57 UTC by Qin Ping
Modified: 2018-04-04 14:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-04 14:01:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qin Ping 2018-04-04 07:57:54 UTC
Description of problem:
No "allowVolumeExpansion" field in "oc describe sc"

Version-Release number of selected component (if applicable):
openshift v3.10.0-0.15.0
kubernetes v1.9.1+a0ce1bc657

How reproducible:
Always

Steps to Reproduce:
1. Enable feature gate "ExpandPersistentVolumes" and admission controller "PersistentVolumeClaimResize"
2. Create a storageclass with allowVolumeExpansion=true
# oc export sc standard
allowVolumeExpansion: true
apiVersion: storage.k8s.io/v1
kind: StorageClass
metadata:
  annotations:
    storageclass.beta.kubernetes.io/is-default-class: "true"
  creationTimestamp: null
  name: standard
parameters:
  fstype: xfs
provisioner: kubernetes.io/cinder
reclaimPolicy: Delete

Actual results:
# oc describe sc standard
Name:            standard
IsDefaultClass:  Yes
Annotations:     storageclass.beta.kubernetes.io/is-default-class=true
Provisioner:     kubernetes.io/cinder
Parameters:      fstype=xfs
ReclaimPolicy:   Delete
Events:          <none>

Expected results:
There is a "allowVolumeExpansion" field in the output.

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Hemant Kumar 2018-04-04 14:01:43 UTC
This is a known limitation because of resizing being a alpha feature in 3.10. It will be handled as part of 1.11 when resizing goes beta. 

I have created a trello card to track this - https://trello.com/c/Bmnirifz/648-display-allowvolumeexpansion-field-in-oc-describe-sc


Note You need to log in before you can comment on or make changes to this bug.