Bug 1563561 - stratis pool create failed
Summary: stratis pool create failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: stratisd
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andy Grover
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 07:58 UTC by lnie
Modified: 2018-05-15 20:04 UTC (History)
5 users (show)

Fixed In Version: stratisd-0.5.2-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 20:04:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
journal (236.23 KB, text/plain)
2018-04-04 07:58 UTC, lnie
no flags Details

Description lnie 2018-04-04 07:58:57 UTC
Created attachment 1417096 [details]
journal

Description of problem:

[root@localhost-live lnie]# stratis pool create test1 /dev/sdc
Execution failed: 
[root@localhost-live lnie]# sudo stratis pool create test1 /dev/sdc
Execution failed: 1: Device /dev/sdc already belongs to Stratis pool 4105cef4-ccbf-45c6-9b2a-af128ca72f56
[root@localhost-live lnie]# stratis fs create test1 filesystem1
Execution failed: No object path found for interface org.storage.stratis1.pool and spec {'Name': 'test1'}



Version-Release number of selected component (if applicable):
stratisd-0.5.0-1.fc28.x86_64
stratis-cli-0.5.0-1.fc28.noarch

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Lukas Ruzicka 2018-04-04 10:23:58 UTC
I have a similar misbehaviour. I would like to complete the test case provided at fedoraproject.org/wiki/User:Grover/Draft/testcase_stratis:  
I cannot create a stratis pool, although I have two unused disks with no filesystems on it. 

lsblk:
----------------------------------------------------------
sda               8:0    0 111.8G  0 disk 
├─sda1            8:1    0   200M  0 part /boot/efi
├─sda2            8:2    0     1G  0 part /boot
└─sda3            8:3    0 110.6G  0 part 
  ├─fedora-root 253:0    0    50G  0 lvm  /
  ├─fedora-swap 253:1    0   6.9G  0 lvm  [SWAP]
  └─fedora-home 253:2    0  53.7G  0 lvm  /home
sdb               8:16   0 232.9G  0 disk 
sdc               8:32   0 298.1G  0 disk 
----------------------------------------------------------

sudo stratis pool create test1 /dev/sdb >
----------------------------------------------------------
Execution failed: 1: Device /dev/sdb appears to belong to another application
----------------------------------------------------------

Of course, I cannot proceed with the testing.

Comment 2 Lukas Ruzicka 2018-04-04 10:25:42 UTC
journactl -b | grep stratis does not show anything relevant.

-----
journalctl -b | grep stratis
Apr 04 11:56:33 localhost.localdomain dbus-daemon[784]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service' requested by ':1.134' (uid=0 pid=2672 comm="sudo dnf install stratis-cli " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
Apr 04 11:56:36 localhost.localdomain sudo[2672]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/dnf install stratis-cli
Apr 04 11:57:43 localhost.localdomain sudo[2823]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis pool create test1 /dev/sdb
Apr 04 11:57:43 localhost.localdomain dbus-daemon[784]: [system] Activating service name='org.storage.stratis1' requested by ':1.139' (uid=0 pid=2824 comm="/usr/bin/python3 -s /usr/bin/stratis pool create t" label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023") (using servicehelper)
Apr 04 11:57:43 localhost.localdomain dbus-daemon[784]: [system] Successfully activated service 'org.storage.stratis1'
Apr 04 11:57:49 localhost.localdomain sudo[2835]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis pool create test1 /dev/sdc
Apr 04 11:58:42 localhost.localdomain sudo[2869]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis list
Apr 04 11:58:50 localhost.localdomain sudo[2877]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis pool list
Apr 04 11:59:14 localhost.localdomain sudo[2917]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis blockdev list
Apr 04 12:08:19 localhost.localdomain sudo[3040]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis pool create test1 /dev/sdc
Apr 04 12:16:19 localhost.localdomain sudo[3392]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis pool create test1 /dev/sdb
Apr 04 12:17:56 localhost.localdomain sudo[3461]: fzatlouk : TTY=pts/0 ; PWD=/home/fzatlouk ; USER=root ; COMMAND=/usr/bin/stratis pool create test1 /dev/sdb
----

Comment 3 mulhern 2018-04-04 19:15:42 UTC
Thanks for the reports!

There are two obvious things we can do:

1. Avoid having an empty string as an explanation of execution failure. We are working on that: https://github.com/stratis-storage/stratis-cli/issues/83.

2. Explain better why stratis thinks the device belongs to another application and can't be touched. How stratis decided device ownership, especially ownership by others, is currently in flux, but we can make sure that when that settles, the explanation of other ownership is better elaborated.

Comment 4 mulhern 2018-04-06 13:30:15 UTC
Improve error messages regarding failures in auto-generated methods that depend on dbus-python as well: https://github.com/stratis-storage/dbus-python-client-gen/issues/12.

Comment 5 Paul K 2018-04-28 18:47:58 UTC
On Fedora 28 Beta, Stratisd v0.5.1, I tried the same and received a similar but equally unhelpful message:

[root@fed28 ~]# stratis pool create mypool /dev/sdb 
Execution failed: 4: entity not found

Is this in the same category or is a new bug warranted?

Comment 6 mulhern 2018-04-30 12:45:19 UTC
Thanks! This error reporting problem is a bit deeper, because it requires work on stratisd, the daemon. It has a GitHub issue: https://github.com/stratis-storage/stratisd/issues/766.(In reply to Paul K from comment #5)
> On Fedora 28 Beta, Stratisd v0.5.1, I tried the same and received a similar
> but equally unhelpful message:
> 
> [root@fed28 ~]# stratis pool create mypool /dev/sdb 
> Execution failed: 4: entity not found
> 
> Is this in the same category or is a new bug warranted?

Thanks! This error reporting problem is a bit deeper, because it requires work on stratisd, the daemon. It has a GitHub issue: https://github.com/stratis-storage/stratisd/issues/766.

Comment 7 Fedora Update System 2018-05-01 23:30:22 UTC
python-dbus-python-client-gen-0.7-1.fc28 stratis-cli-0.5.2-1.fc28 stratisd-0.5.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-72caeabbe0

Comment 8 Fedora Update System 2018-05-02 13:13:38 UTC
python-dbus-python-client-gen-0.7-1.fc28, stratis-cli-0.5.2-1.fc28, stratisd-0.5.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-72caeabbe0

Comment 9 Fedora Update System 2018-05-04 20:11:36 UTC
python-dbus-python-client-gen-0.7-1.fc28 stratis-cli-0.5.2-1.fc28 stratisd-0.5.2-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-72caeabbe0

Comment 10 Fedora Update System 2018-05-06 10:05:36 UTC
python-dbus-python-client-gen-0.7-1.fc28, stratis-cli-0.5.2-1.fc28, stratisd-0.5.2-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-72caeabbe0

Comment 11 Fedora Update System 2018-05-15 20:04:42 UTC
python-dbus-python-client-gen-0.7-1.fc28, stratis-cli-0.5.2-1.fc28, stratisd-0.5.2-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.