Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1563563 - No lbaas test rpm in RHOSP13 puddles.
Summary: No lbaas test rpm in RHOSP13 puddles.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jon Schlueter
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 08:02 UTC by Anshul Behl
Modified: 2018-06-27 13:50 UTC (History)
5 users (show)

Fixed In Version: openstack-neutron-lbaas-12.0.1-0.20180316160204.f2cdc91.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:50:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:50:53 UTC

Description Anshul Behl 2018-04-04 08:02:21 UTC
Description of problem:
I was not able to find any lbaas tests rpm in RHOSP13 puddles

Version-Release number of selected component (if applicable):
RHOSP13

How reproducible:
Everytime

Steps to Reproduce:
1. Check http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/13.0-RHEL-7/2018-03-29.1/RH7-RHOS-13.0/x86_64/os/Packages/
2. or Setup RHOSP13 env
3. No lbaas test rpm present and I was also not able to list the lbaas tempest tests based on the any entrypoints from the neutron test rpms

Actual results:
lbaas tests are not visible or cant be listed

Expected results:
lbaas tests should be visible


Additional info:

Comment 1 Anshul Behl 2018-04-04 08:27:30 UTC
Octavia has only one lbaas tests as below:

octavia_tempest_plugin.tests.v2.api.test_loadbalancer.LoadbalancerTest.test_crud_loadbalancer

If this is the only lbaas test we are looking at for RHOSP13, I would need a confirmation from engineering that we are ok to accept the results of the same in certification too if a partner comes in for lbaas plugin certification

Comment 2 Jon Schlueter 2018-04-04 15:30:48 UTC
Why are we looking in that package and don't have Req's for it in the .spec

Comment 3 Jon Schlueter 2018-04-04 15:41:24 UTC
I see python-neutron-lbaas-tests-12.0.1-0.20180316160204.f2cdc91.el7ost.noarch rpm is the tempest plugin

This will need to be adjusted in product listings

Comment 5 Jon Schlueter 2018-04-04 20:00:34 UTC
should be in next puddle

Comment 11 Jon Schlueter 2018-04-10 13:43:12 UTC
Included in latest puddle for Testing

Comment 15 errata-xmlrpc 2018-06-27 13:50:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.