Bug 1563565 - NetApp: Add use-exact-size parameter when creating a LUN on ONTAP iSCSI
Summary: NetApp: Add use-exact-size parameter when creating a LUN on ONTAP iSCSI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z9
: 10.0 (Newton)
Assignee: Eric Harney
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On: 1572704 1572707
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 08:08 UTC by Meiyan Zheng
Modified: 2018-09-17 16:58 UTC (History)
6 users (show)

Fixed In Version: openstack-cinder-9.1.4-35.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, a bug in the NetApp cinder driver caused volumes created from images to be larger than specified. With this fix, the NetApp driver uses the correct volume size when creating volumes.
Clone Of:
: 1572704 1572707 (view as bug list)
Environment:
Last Closed: 2018-09-17 16:57:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2717 None None None 2018-09-17 16:58:17 UTC

Description Meiyan Zheng 2018-04-04 08:08:50 UTC
Description of problem:

When a cinder volume is created the ontap backend fits the LUN to the
best geometry. It makes the image uploaded from a volume larger than
expected and a volume of larger size must be created from that image.
Using the use-exact-size parameter the backend does not fit to best
geometry, the image uploaded from that volume has the same size and a
volume of the same size may be created from that image.

Upstream bug is fixed, any plan to merge this to RHOSP? 


[1] https://bugs.launchpad.net/cinder/+bug/1731474
[2] https://git.openstack.org/cgit/openstack/cinder/commit/?id=67391f1f0f30172190882e7d3f4a4ddc271dfa00


Version-Release number of selected component (if applicable):




How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 15 Alex McLeod 2018-09-03 07:57:40 UTC
Hi there,

If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field.

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Thanks,
Alex

Comment 17 errata-xmlrpc 2018-09-17 16:57:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2717


Note You need to log in before you can comment on or make changes to this bug.