Bug 1563567 - Change CD dialog lists isos in non-ordered way, dialog list too small
Summary: Change CD dialog lists isos in non-ordered way, dialog list too small
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.2.4
: ---
Assignee: Tal Nisan
QA Contact: Shir Fishbain
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 08:17 UTC by Jiri Belka
Modified: 2018-06-26 08:42 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:42:05 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
ylavi: blocker-
ylavi: exception+
ebenahar: testing_plan_complete-


Attachments (Terms of Use)
change CD dialog (75.04 KB, image/png)
2018-04-04 08:17 UTC, Jiri Belka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91288 0 master MERGED webadmin: Order CD selection by name 2018-05-17 07:28:45 UTC
oVirt gerrit 91309 0 ovirt-engine-4.2 MERGED webadmin: Order CD selection by name 2018-05-21 14:22:19 UTC
oVirt gerrit 91441 0 master MERGED webadmin: Enlarge change CD dialog height to show more ISOs 2018-05-22 14:53:56 UTC
oVirt gerrit 91498 0 ovirt-engine-4.2 MERGED webadmin: Enlarge change CD dialog height to show more ISOs 2018-05-22 15:51:13 UTC

Description Jiri Belka 2018-04-04 08:17:54 UTC
Created attachment 1417112 [details]
change CD dialog

Description of problem:

Change CD dialog used to list isos in ordered way, it does not now. The dialog is also too small. See screenshot (my resolution is 1080x1920).

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.2.6-0.1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. check isos order in Change CD dialog
2.
3.

Actual results:
not ordered correctly, the dialog list is too small

Expected results:
nice order, seeing more items in the list

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2018-04-04 12:44:57 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Doron Fediuck 2018-05-15 15:31:06 UTC
Closing for lack of capacity as this is a low severity issue.
If needed please reopen and explain why.

Comment 3 Lukas Svaty 2018-05-16 08:22:20 UTC
It's pretty common to have stored all the old iso for used OSes which brings a huge list, please reconsider expanding the list size and ordering it as at the moment it is not user-friendly for customer-like scenarios to read through all the labels scroll around and keep looking for the right version based on date of release.

Example:
Ubuntu-201610.iso
Ubuntu-201602.iso
Ubuntu-201710.iso
Ubuntu-201702.iso
Ubuntu-201810.iso
Ubuntu-201802.iso
Ubuntu-201910.iso
Ubuntu-201902.iso
Ubuntu-202010.iso
Ubuntu-202002.iso

Without ordering it and showing just 4 of them, the user will have to scroll around.

Comment 4 Shir Fishbain 2018-06-11 09:04:56 UTC
The resolution of the change CD dialog is 400x170

Comment 5 Sandro Bonazzola 2018-06-26 08:42:05 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.