Bug 1563588 - Following update documentation leads to errors
Summary: Following update documentation leads to errors
Keywords:
Status: CLOSED DUPLICATE of bug 1560578
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Documentation
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: 5.8.4
Assignee: Red Hat CloudForms Documentation
QA Contact: Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 08:55 UTC by Sebastián Greco
Modified: 2018-06-04 06:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-04 00:12:13 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Sebastián Greco 2018-04-04 08:55:10 UTC
Document URL: https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.6/pdf/migrating_to_red_hat_cloudforms_4.6/Red_Hat_CloudForms-4.6-Migrating_to_Red_Hat_CloudForms_4.6-en-US.pdf

Section Number and Name: 1.5 Migrating from CFME 5.8 to 5.9

Describe the issue: Following the guide, leads to an error and a broken CFME when trying to run the command "rake db:migrate" on a standalone CFME (vsphere appliance).

[root@cloudforms ~]# cd /var/www/miq/vmdb/
[root@cloudforms vmdb]#  rake db:migrate
Could not find psych-2.0.17 in any of the sources
Run `bundle install` to install missing gems. 


Additional information: 
Checking installed version
[root@cloudforms vmdb]# gem list --local | grep -i psych
psych (2.1.0.1)

Running "bundle install" to fix error, gives warning about running it as root user and also fails
[root@cloudforms vmdb]# bundle install
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this application for all non-root users on this machine.
Fetching gem metadata from https://rubygems.org/........
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Fetching https://github.com/ManageIQ/manageiq-gems-pending.git
Fetching https://github.com/ManageIQ/handsoap.git
Fetching https://github.com/ManageIQ/amazon_ssa_support.git
Fetching https://github.com/ManageIQ/foreman_api_client.git
Fetching https://github.com/ManageIQ/jquery-rjs.git
Fetching https://github.com/ManageIQ/manageiq-api
Fetching https://github.com/ManageIQ/manageiq-automation_engine
Fetching https://github.com/ManageIQ/manageiq-consumption
Fetching https://github.com/ManageIQ/manageiq-content
Fetching https://github.com/ManageIQ/manageiq-messaging
Fetching https://github.com/ManageIQ/manageiq-providers-amazon
Fetching https://github.com/ManageIQ/manageiq-providers-ansible_tower
Fetching https://github.com/ManageIQ/manageiq-providers-azure
Fetching https://github.com/ManageIQ/manageiq-providers-foreman
Fetching https://github.com/ManageIQ/manageiq-providers-google
Fetching https://github.com/ManageIQ/manageiq-providers-hawkular
Fetching https://github.com/ManageIQ/manageiq-providers-kubernetes
Fetching https://github.com/ManageIQ/manageiq-providers-lenovo
Fetching https://github.com/ManageIQ/manageiq-providers-nuage
Fetching https://github.com/ManageIQ/manageiq-providers-openshift
Fetching https://github.com/ManageIQ/manageiq-providers-openstack
Fetching https://github.com/ManageIQ/manageiq-providers-ovirt
Fetching https://github.com/ManageIQ/manageiq-providers-scvmm
Fetching https://github.com/ManageIQ/manageiq-providers-vmware
Fetching https://github.com/ManageIQ/manageiq-schema
Fetching https://github.com/ManageIQ/manageiq-ui-classic
Your bundle is locked to redhat_access_cfme (2.0.2), but that version could not be found in any of the sources listed in your Gemfile. If you haven't changed sources, that means the author of redhat_access_cfme (2.0.2) has removed it.
You'll need to update your bundle to a different version of redhat_access_cfme (2.0.2) that hasn't been removed in order to install.

After that command fail, trying to rerun "rake db:migrate" still fails with another error.
[root@cloudforms vmdb]# rake db:migrate
Could not find nokogiri-1.8.1 in any of the sources
Run `bundle install` to install missing gems.

[root@cloudforms vmdb]# gem list | grep -i nokogiri
nokogiri (1.8.1)

Comment 9 Andrew Dahms 2018-06-04 00:12:13 UTC
Hi Sebastián,

Thank you for reporting this bug, and my apologies for the delay in following up and providing you with a reply.

After following up with engineering, we have discovered that the issue you reported was caused by an issue reported in the following engineering bug -

https://bugzilla.redhat.com/show_bug.cgi?id=1560578

Because that issue has now been resolved, I will close this documentation bug in its role as a tracker.

Please let us know if there is anything else we can help with.

Kind regards,

Andrew

*** This bug has been marked as a duplicate of bug 1560578 ***

Comment 10 Sebastián Greco 2018-06-04 06:53:52 UTC
(In reply to Andrew Dahms from comment #9)
> Hi Sebastián,
> 
> Thank you for reporting this bug, and my apologies for the delay in
> following up and providing you with a reply.
> 
> After following up with engineering, we have discovered that the issue you
> reported was caused by an issue reported in the following engineering bug -
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1560578
> 
> Because that issue has now been resolved, I will close this documentation
> bug in its role as a tracker.
> 
> Please let us know if there is anything else we can help with.
> 
> Kind regards,
> 
> Andrew
> 
> *** This bug has been marked as a duplicate of bug 1560578 ***

Excellent! Thanks for the update and sorry I duplicated the bug ( I was unable to find the original one before opening this other).


Note You need to log in before you can comment on or make changes to this bug.