Bug 15636 - problem with dependencies
problem with dependencies
Status: CLOSED DUPLICATE of bug 16684
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-07 09:25 EDT by mal
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 09:53:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is a SPEC file I used. (570 bytes, text/plain)
2000-08-07 09:53 EDT, mal
no flags Details

  None (edit)
Description mal 2000-08-07 09:25:42 EDT
In some cases (for example when doing rpm -Fvh)
rpm failes with dependencies and installs the same package twice.
This is an example: test 2,3,4 are the same package
the only difference is package revision
(you can use any package for this).

[root@eth0_extrenal noarch]# rpm -Uvh test-1.0-2.noarch.rpm 
[root@eth0_extrenal noarch]# rpm -q test
test-1.0-2
[root@eth0_extrenal noarch]# rpm -Fvh test-1.0-3.noarch.rpm
test-1.0-4.noarch.rpm 
findMatches: cannot read header at 0x3a8
[root@eth0_extrenal noarch]# rpm -Fvh test-1.0-3.noarch.rpm 
[root@eth0_extrenal noarch]# rpm -Fvh test-1.0-4.noarch.rpm 
[root@eth0_extrenal noarch]# rpm -Fvh test-1.0-*            
[root@eth0_extrenal noarch]# rpm -q test
test-1.0-3
test-1.0-4

# rpm -q rpm
rpm-4.0-0.59

See, test package now installed TWICE.
Now the only way to fix this is
rpm --rebuilddb
Comment 1 mal 2000-08-07 09:53:13 EDT
Created attachment 2175 [details]
This is a SPEC file I used.
Comment 2 Jeff Johnson 2000-09-05 10:11:43 EDT
This is a variant of  #16684 (i.e. multiple identically named packages).

*** This bug has been marked as a duplicate of 16684 ***

Note You need to log in before you can comment on or make changes to this bug.