Bug 1563614 - satellite-installer --katello-pulp-max-speed leads to broken pulp
Summary: satellite-installer --katello-pulp-max-speed leads to broken pulp
Keywords:
Status: CLOSED DUPLICATE of bug 1625923
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Chris Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 10:12 UTC by daniel
Modified: 2019-04-01 20:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-06 17:22:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
satellite-installer --katello-pulp-max-speed 10MB (76.81 KB, image/png)
2018-06-18 16:08 UTC, Chris Brown
no flags Details
yum_importer.json (254 bytes, text/plain)
2018-06-18 16:09 UTC, Chris Brown
no flags Details

Description daniel 2018-04-04 10:12:29 UTC
Description of problem:
using
# satellite-installer  --katello-pulp-max-speed 10MB
leaves pulp broken


Version-Release number of selected component (if applicable):
satellite-6.3.0.1-1.el7sat.noarch

How reproducible:


Steps to Reproduce:
1. install satellite 6.3 as per documentation
2. try to add speed limitation: # satellite-installer  --katello-pulp-max-speed 10MB
3. afterwards pulp is not working anymore:
# hammer ping
candlepin:      
    Status:          ok
    Server Response: Duration: 17ms
candlepin_auth: 
    Status:          ok
    Server Response: Duration: 21ms
pulp:           
    Status:          FAIL
    Server Response:
pulp_auth:      
    Status: FAIL
foreman_tasks:  
    Status:          ok
    Server Response: Duration: 490ms

#


Actual results:
pulp broken because of wrongly set value in /etc/pulp/server/plugins.conf.d/yum_importer.json 

# cat /etc/pulp/server/plugins.conf.d/yum_importer.json 
{
    
    "proxy_host": null,
    
    
    "proxy_port": null,
    
    
    "proxy_username": null,
    
    
    "proxy_password": null,
    
        "max_speed": 10485760"
    
}
#

--> there are " missing in front of the value

Expected results:
should add value in a way that it is supported

Additional info:

changing "max_speed": 10485760" 
to       "max_speed": "10485760"
and restarting satellite makes it work again

Comment 2 daniel 2018-04-12 17:37:17 UTC
actually, after some testing I think 

        "max_speed": 10485760

(w/o quotes) is correct setting as putting the speed value in quotes makes pulp work again but syncs still fail. They work when the value is set w/o quotes, at least in my env

Comment 3 Chris Brown 2018-06-18 16:08:05 UTC
Created attachment 1452677 [details]
satellite-installer --katello-pulp-max-speed 10MB

Results from running the command satellite-installer --katello-pulp-max-speed 10MB. pulp status is now ok instead of FAIL

Comment 4 Chris Brown 2018-06-18 16:09:11 UTC
Created attachment 1452678 [details]
yum_importer.json

Comment 6 Sean O'Keeffe 2018-09-06 17:22:20 UTC

*** This bug has been marked as a duplicate of bug 1625923 ***


Note You need to log in before you can comment on or make changes to this bug.