Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1563638 - AttributeError: 'NoneType' object has no attribute 'clear'
Summary: AttributeError: 'NoneType' object has no attribute 'clear'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-04 11:25 UTC by Xiaodai Wang
Modified: 2019-08-06 13:08 UTC (History)
5 users (show)

Fixed In Version: virt-manager-1.5.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:07:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-manager debug log (31.32 KB, text/plain)
2018-04-04 11:26 UTC, Xiaodai Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2232 0 None None None 2019-08-06 13:08:11 UTC

Description Xiaodai Wang 2018-04-04 11:25:50 UTC
Description of problem:
AttributeError: 'NoneType' object has no attribute 'clear'

Version-Release number of selected component (if applicable):
virt-manager-1.4.3-3.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open virt-manager
2. Open a new 'Configure network interface' dialog.
3. keep interface type as Bridge, click 'Forward'.
4. Click 'Configure', then set IPv4 Mode to 'Static'.
5. Close the Ip configuration dialog, an Error validating IP configuration dialog will pop up.
6. Close the error dialog and 'Cancel' the configure network interface dialog.
7. Click '+' to open a new 'configure network interface' dialog.


Actual results:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/host.py", line 756, in add_interface
    self.addinterface.show(self.topwin)
  File "/usr/share/virt-manager/virtManager/createinterface.py", line 122, in show
    self.reset_state()
  File "/usr/share/virt-manager/virtManager/createinterface.py", line 363, in reset_state
    self.widget("ipv6-address-list").get_model().clear()
AttributeError: 'NoneType' object has no attribute 'clear'

Expected results:
The new 'configure network interface' dialog should be launched successfully.

Additional info:

Comment 1 Xiaodai Wang 2018-04-04 11:26:35 UTC
Created attachment 1417240 [details]
virt-manager debug log

Comment 5 ysu@redhat.com 2019-04-23 05:11:55 UTC
I can reproduce this issue with package:
virt-manager-1.4.3-3.el7.noarch

Then try to verify this bug with new build:
virt-manager-1.5.0-3.el7.noarch
virt-install-1.5.0-3.el7.noarch
libvirt-4.5.0-12.el7.x86_64
qemu-kvm-rhev-2.12.0-26.el7.x86_64
libvirt-python-4.5.0-1.el7.x86_64

1. Check the ip-config window can be closed even for incorrect configuration when creating new host network interface.
1.1 Open virt-manager.
1.2 Open a new 'Configure network interface' dialog.
1.3 Keep interface type as Bridge, click 'Forward'.
1.4 Click 'Configure', then set IPv4 Mode to 'Static'.
1.5 Click 'OK' to make it work.

Result: An Error validating IP configuration dialog will pop up:'Error validating IP configuration:Please enter an IP address'.

1.6 Close the error dialog and click the close button 'X' in the upper right corner of the configure network interface dialog.

Result: The dialog can not close and the Error as the result of step1.5 will pop up again until changing IPv4 Mode from static to dhcp or none configuration.

1.7 New 'configure network interface' dialog can open successfully.

Results:Open host network interface successfully.
The result of Step1.6 is confused.I can't close the incorrect configuration directly by click 'X'.

Comment 6 Pavel Hrdina 2019-04-23 11:30:14 UTC
It's not ideal but it would require to refactor the code and since this was completely dropped from upstream and I would consider it as a corner case I don't think we should waste anymore time to improve it.

Comment 7 ysu@redhat.com 2019-04-29 03:33:39 UTC
Thanks for you replication,so i move this bug from ON_QA to VERIFIED based on above testing.

Comment 9 errata-xmlrpc 2019-08-06 13:07:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2232


Note You need to log in before you can comment on or make changes to this bug.